Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Developer
Posts: 137
Registered: ‎06-01-2009
My Device: Not Specified

Module has verification errors.Error starting -- using Eclipse 3.5 and JDE 1.1 using 9550 simulator

I am getting the error: Module 'xxxx' has verification errors.Error starting xxxx: Module 'xxxx' has verification errors When try to run it using Eclipse 3.5.1 and JDE 1.1 and 9550 simulator.

 

The error occurs at the entry, when I click on the icon application. The same application works fine using Eclipse 3.4 and JDE 1.0 and 9530 simulator.

 

I run some samples on 3.5 and JDE 1.1 and they run fine. However not able to run my application. when click on the application icon, I get the error mentioned above. Not able to debug because the exception happens at the entry point.

 

I used JDE 4.7.0 in the two cases above.

BlackBerry Development Advisor
Posts: 15,727
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Module has verification errors.Error starting -- using Eclipse 3.5 and JDE 1.1 using 9550 simul

Please refer to the following.

 

Support - Preventing verification errors
Article Number: DB-00744

http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800332/832062/Support...

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Highlighted
Developer
Posts: 35
Registered: ‎10-11-2008
My Device: Not Specified

Re: Module has verification errors.Error starting -- using Eclipse 3.5 and JDE 1.1 using 9550 simulator

I understand this is an old post.

 

But I am using Eclipse Plug In 1.5 and got the same problem after executing a "Clean" to 9300 simulator.

My scenario is that my application uses external "cod" files not related in the build path.

I launch the debugger, click on the app, "Module XXX has verification errors".

 

Solution:

Find the directory where the simulator is installed and the debug application is deployed.

Ex. G:\program files\Research In Motion\Blackberry Smarthphone Simulators 5.0.0\5.0.0.977 (9300)\

Copy the external cod files to the directory.

Relaunch the debugger.

 

Hope this helps.