Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Visitor
Posts: 1
Registered: ‎04-20-2010
My Device: Not Specified

Module has verification errors

I am developing a MIDlet application that I am trying to run in the blackberry simulator. When I start the application in the simulator, I get the "Module 'MyApp' has verification errors. As far as I understand this normally has to do with using some library that is not supported? I can not understand where I include anything that is not supported, and was hoping somebody here can help me!

 

I am building the application in JDE 5.0. I also tried in JDE 4.7, but get the same errors there.

I am currently using simulator 9550, have also tried 9700, 9630, 9500. Same problem.

 

The application consists of a main jar-file MyApp and a framework jar-file (Framework.jar) that I am using. I have complete control over the Framework.jar also.

 

If I build only MyApp, removing all usages of Framework.jar, it works fine. It builds and runs as expected.

One of my classes is supposed to extend a class in the Framework.jar. As soon as I do this, the problem arises. It still builds with no errors, but gets the verification error when running in the simulator.

The only thing I change is the class declaration.

This works:

 

public class AppClass {

 

 

This does not work:

 

public class AppClass extends FrameworkClass {

 

 

I have tried removing everything from the framework. The Framework.jar now only contains ONE class (the one I want to extend, FrameworkClass.java), with an empty constructor, no other methods, and no references to anything else!

 

I have tried using preverify.exe on both Framework.jar and MyApp.jar, that returns no error messages.

 

Any ideas?

Developer
Posts: 16,997
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Module has verification errors

this should help you:

http://www.blackberry.com/knowledgecenterpublic/livelink.exe/Support_-_Preventing_verification_error...

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
New Contributor
Posts: 2
Registered: ‎03-06-2010
My Device: 9800
My Carrier: TMOBILE

Re: Module has verification errors

I am having the same issue.

 

What is the solution

 

I have read that long bullet points and it doesn't appy

 

can you not simply import thrid party jars in yor application???

Contributor
Posts: 14
Registered: ‎10-20-2012
My Device: Torch 9800
My Carrier: airtel

Re: Module has verification errors

Simon,

the link you gave is not working anymore. Please provide a new link if available.

Thanks,

Paramvir Singh

Developer
Posts: 16,997
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Module has verification errors

you could enter a search term related to that and get the new link, i did that for you:
http://supportforums.blackberry.com/t5/Java-Development/Preventing-verification-errors/ta-p/444846
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter