Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Posts: 52
Registered: ‎07-17-2008
My Device: Not Specified

My app wrecks 8130 Pearl (Verizon)

The 8130 goes into an infinite reboot loop as soon as my app is installed. I have not found a way to recover it from this state.   I tried uninstalling the app using the app loader, but apploader hangs while connnecting to the device.


The app runs just fine on almost all other BlackBerry models.  Not sure what is special about 8130 that renders the phone useless upon installign an app.   Only thing special about this app is that it uses alternate entry point to run in background. 


First I thought this could be due to an incompatible COD because the app was built using JDE 4.2.   CODs are suppossed to be forward compatible, but still to be sure, I built the app using JDE 4.3.  UGH... Another 8130 got destroyed when I loaded the 4.3 build.   


Here are my questions:


1. How exactly one can debug this issue (There are no issues when I run the app on 8130 simulator)

2. Is there a known issue with 8130.

3.  How to recover the device without losing the data?





Note: 8130s we have are running OS software  version 4.3

Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: My app wrecks 8130 Pearl (Verizon)

Two issues here:

1) Recovering your 8130

2) Debugging your app.


Starting with (1).  It sounds like either:

a) Your app is autostarted, and this is causing an Exception, that causes the BB to restart.

b) There is a compatibility error in the generated cod - see Mark Sohm's comment on this thread:



I've managed to recover a device that had the problem (b) by following the "Recovery Instructions" given later (these instructions are cut/pasted from the old forum).  I screwed it up by installing a 4.2 application on a 4.1 device.  Note that when following these instructions, the data on the device is lost.  Sorry.  Better a live 813o with no data than a dead one with data I suspect!


Now onto (2) - debugging.


If your application is autostarted, then it could be something in that process.  I would regenerate the application without autostart, install and reboot.  If that works, then you could set up an alternate entry point (and icon) that does the startup processing and debug this with the device attached.  There is only one problem with this, and that is when this processing is running, the device is actually powered up, so if there is any processing in the autostart that can only run when the device is fully powered up, you will not see the problem.  See the following very useful KB article:


How to - Detect system availability on startup 
Article Number: DB-00642



I would also put try/catch around the start up processing and log any errors you have.


If however your app is NOT autostarted, then I'm sorry I can't help.  Hopefully someone in RIM can.


Recovery Instructions:


The only way that I know to recover this device involves reloading the OS. This will effectively wipe the device, but I presume a completely wiped 8700 is better than no device at all, so here are the steps.


These are from memory, it has been a while since I did this. I can't remember where I found this, I'm reasonably sure it was on this forum though.


Assuming you have not already done so, download and install (on your PC) an OS for your device, You should find this from your carrier, but if you have trouble, then this link might be useful:

Note: this link is not working for me at present, but I think it is a problem here.  The following link is working and you should be able find further instructions from here:



Once you have downloaded and installed this, then you need take advantage of the small window at boot up time when the device will 'connect' to the PC. So get your Desktop Manager started, start Application Loader (onto the Welcome screen which says 'Next'), and get the USB cable ready. Then, quickly, remove and reinstall the battery, plug the device into the USB cable, press 'Next', and hopefully the application loader will find the device and display the USB connection in the "Drop down" list labeled Connection. Quickly press Next to connect to it, and it will stop the start up processing and allow you to reinstall the OS.


You will then get the normal application loader screen with all the OS components to install.


You can try this procedure without installing the OS, to make yourself familiar with it and the timing involved. It is a bit hit and miss for me so keep trying if you don't get it first time - once the device gets to a white screen with the hour glass, I think you have missed it (so pull the battery and try again). Note if you pull the battery while connected to USB, it is not guaranteed to reboot because it can get its power from the USB.


Unfortunately, it does not give you the opportunity to delete your own applications at this point.


[Note that I have had the following comment added with respect to these instructions:


As you describe, i had to download the OS and run the application loader, but the difference is that i had to remove the battery in the first part of the process.

When you install the OS loader do the steps:
1) the loader install the OS (i did this without the battery only with USB connected)
2) restart device (while restarting i restore the battery without remove the USB)
3) install applications and finish the process.]


Posts: 52
Registered: ‎07-17-2008
My Device: Not Specified

Re: My app wrecks 8130 Pearl (Verizon)

[ Edited ]
Peter, much appreciate your detailed response.  I will use your tips to debug the issue and post the update here soon.  This is going to be more fun than Mardi Grass party.
Message Edited by akirekadu on 08-26-2008 03:50 PM