Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Highlighted
New Developer
Posts: 4
Registered: ‎09-16-2009
My Device: Not Specified

Need a Full BlackBerry Developer Kit install for Vista 64 bit machine.

Hello,

 

I am trying to develop my first applicaton.  Here are the specs for my machine and my smartphone:

 

Vista 64 bit, plenty of everything needed to run apps.

blackberry 8700 v4.1.0.284

 

My question is there a complete install that will give me all the appropiate applications to start developing without having to install each application seperately?

 

Ex:  Eclipse, Eclipse plugin for blackberry, JDE component pack, with simulators.

 

I've installed all the applications individually but I am unable to get anything to work.

 

Ex:  Eclipse 3.4.2, Blackberry JDE v 1.0.0.67, JDE 4.5 component pack, and simulators.

 

I am trying to develop a Location Based Application.

 

Please help,

Stang

 

Developer
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Need a Full BlackBerry Developer Kit install for Vista 64 bit machine.

[ Edited ]

First off, the Eclipse plugin doesn't support anything before OS 4.2 (AFAIK). Maybe someone else can ring in on this.

 

Second, you are using the wrong device to develop location-based app - the 8700 doesn't have GPS support.

 

I think if you search the forum for "Vista" you will find many threads discussing issues related to the 64-bit OS.

 

If you want to develop for a device that is actually in production, I would suggest going back no further than a Curve running 4.2.1. The 8310 and 8330 both have GPS.

 

Also look at the Bold or Storm - both are popular devices with GPS. You can simulate GPS on the emulator for these devices for development purposes.

 

Message Edited by RexDoug on 09-16-2009 07:00 PM
New Developer
Posts: 4
Registered: ‎09-16-2009
My Device: Not Specified

Re: Need a Full BlackBerry Developer Kit install for Vista 64 bit machine.

What about the 8300 running v 4.2.2.114?

 

Will that work?

 

Also,  what is the best combination of applications to install to develop an app for this smartphone?

Developer
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Need a Full BlackBerry Developer Kit install for Vista 64 bit machine.

No GPS on the 8300, either, unless you attach a bluetooth puck.

 

See this article:

 

http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800332/800703/What_Is...

 

 

If you aren't experienced with Eclipse, I suggest you get started with the JDE. Use JDE 4.2.1 for this device.

 

 

New Developer
Posts: 4
Registered: ‎09-16-2009
My Device: Not Specified

Re: Need a Full BlackBerry Developer Kit install for Vista 64 bit machine.

Thank you...that helps becuase I would like to do autonomous LBS for any blackberry smartphone.  My problem is i cannot get all the applications to work together.

 

What is the best app versions to install for programming an LBS system on a blackberry phone ( autonomous )?

 

JDK Version

JDE Version

Eclipse, Netbeans, or just the IDE

Blackberry plugin, simulator etc...

 

I am running VISTA 64 BIT....does that matter???

 

Like I said I am new but very interested.

 

Please advise,

CG