Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 206
Registered: ‎02-22-2011
My Device: BB TORCH & 9800
My Carrier: idea

Need jdk 1.2/J2SE-1.2 to install for windows 7

[ Edited ]

Hi all,

I need jdk 1.2/J2SE-1.2 to install for windows 7, 

I tried and installed one but in it's description its mentitioned windows 2000 , NT , XP ..etc.,

Its not inluded for windows 7.

when im trying to install that nothing is happening may be the problem with windows 7 but not sure.

So can anyone tell me how and where can i get the jdk 1.2 / J2SE-1.2 to download

 

 

NOTE: In BlackBerry Plugin we can navigate to different jdk versions (fromm1.2 to 1.6) by changing in the Execution environment. but I need seperately to download my required software.

 

Thaks in Advance.

 

*****************************************************************************
* Give kudos when you like it
* Mark it as a solution if it fixes your issue
Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Need jdk 1.2/J2SE-1.2 to install for windows 7

I am confused by this requirement.  I do not see that you neeed this.  I use Eclipse with Java 1.6.  I think I told Eclipse somewhere to compile with code compatible with 1.3 but I do not have any other Java installed. 

 

So why do you need this?

Developer
Posts: 206
Registered: ‎02-22-2011
My Device: BB TORCH & 9800
My Carrier: idea

Re: Need jdk 1.2/J2SE-1.2 to install for windows 7

[ Edited ]

Hi peter,

My main requirement is in below thread,

http://supportforums.blackberry.com/t5/Java-Development/Java-Accessibility-issue-quot-class-of-defau...

So inorder to access a method of a class which is in default-package
into a class of some user created package the way I found with Reflection mechanism.

But without reflection technique straight forward I'm achieving ( that accessibility issue) in jdk 1.2, I have checked it today.

I have to install this jdk in other machine.

*****************************************************************************
* Give kudos when you like it
* Mark it as a solution if it fixes your issue
Developer
Posts: 16,998
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Need jdk 1.2/J2SE-1.2 to install for windows 7

that won't work
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Posts: 206
Registered: ‎02-22-2011
My Device: BB TORCH & 9800
My Carrier: idea

Re: Need jdk 1.2/J2SE-1.2 to install for windows 7

Hi simon,
could you describe more for your above reply "that won't work ".
Are you talking about installation of jdk 1.2 in windows 7 or accessibility issue.

*****************************************************************************
* Give kudos when you like it
* Mark it as a solution if it fixes your issue
Developer
Posts: 16,998
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Need jdk 1.2/J2SE-1.2 to install for windows 7

check the system requirements for eclipse + plugin:
https://developer.blackberry.com/java/download/requirements/
Runtime environment Java SE Development Kit (JDK) 6 32b, update 14 or later

you cannot run eclipse+plugin on java 1.2, even j2me is build on a higher java level.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter