Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

New Developer
Posts: 9
Registered: ‎10-15-2008
My Device: Not Specified

Netbeans: Simulator launches, but app doesn't load/run

[ Edited ]

I'm developing in Netbeans, and using the Blackberry plugins from Netbeans site.  Everything goods fine as far as the editor.  When I right-click to RUN my project, the simulator launches, but the application doesn't load nad run (I'm brought to the home screen).  I even tried opening the java program from the simulator's FILE menu.  I checked the applications folder, and the downloads folder, but it's not registered with the simulator.


Additionally, I tried debugging, but I get various messages stating that *.debug files are missing.  I choose to ignore these since they appear to be *.debug files for all the other app/classes that exists on the device.  Note: a debug confgiuration window open with the simulator, but it doesn't look like there are any setting there which would resolve this problem.


Has anyone got this working?  I'd prefer to launch the simulator to run and debug directly from netbeans, if I can. I have read that some use the Blackberry JDE for using hte simulator, but I can't figure out how to load my Netbeans java project into that IDE.


Any help would be appreciated.



Message Edited by groverblue on 10-29-2008 12:10 PM
New Developer
Posts: 54
Registered: ‎10-07-2008
My Device: Not Specified

Re: Netbeans: Simulator launches, but app doesn't load/run



I had exactly the same problem


Please follow the instruction in this link Netbeans BlackBerry


Pay special attention to the step 4 in the Create a simple Blackberry Application Section, create a empty .alx file and build.xml, this is escential because there you fill the instructions to load your app into the simulator.


Hope it helps.



Posts: 62
Registered: ‎10-29-2008
My Device: 9800
My Carrier: Rogers

Re: Netbeans: Simulator launches, but app doesn't load/run

also be sure to set the MIDlet properties


Right click on your project > Properties > Application Descriptor > MIDlets > Add


Then add the name of your app, and the name of the main class.