Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
New Developer
Posts: 3
Registered: ‎02-22-2011
My Device: Curve 3G 9300
My Carrier: ATT
Accepted Solution

Newbie Question: Multiple SDK's & Plugins per Eclipse Installation?

Hi ,

 

Please excuse if this is a stupid question, but I'm new at BB development.

Can I have more than one SDK & Plug-In version installed in one Eclipse install?  I understand that the latest SDK requires the latest Eclipse version, but if I want to develop for features in BB 5.0, 4.7,4.5, etc, do I need a different IDE install for each SDK/Plugin version or can they co-exist?

 

Thanks for your replies,

 

Jose

Developer
Posts: 656
Registered: ‎02-03-2010
My Device: Z10 LE
My Carrier: Rogers

Re: Newbie Question: Multiple SDK's & Plugins per Eclipse Installation?

You can have all of those active in one Eclipse install.  


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
Developer
Posts: 122
Registered: ‎09-15-2010
My Device: BB - 9800

Re: Newbie Question: Multiple SDK's & Plugins per Eclipse Installation?

hi there, 

 

        You can develop bb applications from 6.0, 5.0,4.7,4.6 and 4.5 using BlackBerry Java Plug-in for Eclipse. 

 

       Inorder get the BB Java plug in, use the below link and download the latest plug in( ver 1.3).

 

                                     http://us.blackberry.com/developers/javaappdev/javaplugin.jsp

 

    By default, you can develop app for 6.0, For earlier versions you need to download the SDKs, in this precedure,

 

       Open Eclipse IDE< Help<Install New Software<Add Site

 

                       http://www.blackberry.com/go/eclipseUpdate/3.6/java

 

 Add the above site and name it as "Blackberry sdk update".

 

and select all the SDKs and download.

 

 

If you think this information is helpful, give kudos

Regular Contributor
Posts: 70
Registered: ‎06-15-2011
My Device: Bold 9900
My Carrier: Bell Canada

Re: Newbie Question: Multiple SDK's & Plugins per Eclipse Installation?

Thank you!!