Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
Posts: 2
Registered: ‎07-28-2009
My Device: Not Specified

Re: No definition found for exported static routine: .main(String[])

I have a similar problem.
Install de Plugin,etc.etc..
Then:

1.-I copy and paste a demo, I compile and it worked.

2.-After that I changed the original workspace ( the first workspace that i had used) and i get this configuration warnings-error.
[
Warning!: No entry points found
Warning!: No definition found for exported static routine: .main(String[])
]

 
A simply solution (for me)
I went back to using the first workspace and returned to work. ! Smiley Happy

The other solution is to re-configure the paths but I can't do it.
How do you do bibodo?

 

Greetings & sorry by mi english Smiley Wink

Developer
Posts: 23
Registered: ‎04-22-2009
My Device: Not Specified

Re: No definition found for exported static routine: .main(String[])

Hi mayofunk,

 

You have to open the classpath configuration dialog and check whether the classpath is plausible.

Especially the binary path should point to a vaild location (usually bin/) 

 

Best Regards

bibodo 

New Developer
Posts: 2
Registered: ‎07-28-2009
My Device: Not Specified

Re: No definition found for exported static routine: .main(String[])

Hi ! Thanks for the answer !

But i think that my problem is other. The paths and their configurations are the same on diferents wk's, and seems to be fine.

I did a few test with diferents locations for my workspace and i have some interesting results.

I have installed eclipse on C:\=PA=\eclipse. (yes, with the equals signs)
The first workspace (n°1) was on C:. Works !
The second wk (n°2) was on letter D:. No Works Smiley Sad !

Then i chose other workspace (n°3) on drive C and it works !
After that, i chose other wk (n°4) on drive D and : it works again ! (whats happens with the second workspace??? )

 
mm,,, i saw that the second wk (n°2), was on D:\=somenamepath=\workspace !
Seems that the "equals signs" are confusing eclipse.*

Well, only lack one test!
I did a new workspace on drive C, on c:\=something=\wkTest and i get the error again !

As conclusion i think that the "equals signs" on my paths was the problem, maybe other "special characters" may cause the problems.

 

 

* I don't know if that sentence (or others) is grammatically correct, any sugestion of my english are welcome !.
Greetings !

Highlighted
Regular Contributor
Posts: 81
Registered: ‎01-16-2012
My Device: BOLD 9650 + developer
My Carrier: Vodafone

Re: No definition found for exported static routine: .main(String[])

dear bibode ,
can u provide us with the steps of how to fix the classpath