Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Highlighted
Developer
Posts: 73
Registered: ‎10-23-2009
My Device: Not Specified

OS 6 Torch build different than OS 5 build

I have a production app I'm working on a new version of that we are testing on the Torch.  I have found the following to be true:

 

Build the code against JRE 4.7 - Run on a Storm device using OS 5.0, everything works.  Run on a Torch using OS 6.0, some of the dynamically positioned button bars are not displayed (ones that move on device Rotate)

 

Build the code against JRE 6.0 - Run on a Torch using OS 6.0 ........ everything works!  It behaves exactly as it did on the Storm with the JRE 4.7 build.

 

I have no precompiler ifdef / ifndef that reference the built in JRE tags.  The code wasn't changed at all between builds, just the referenced JRE.

 

I thought the OS was supposed to support running existing apps fairly well?  In general are we not supposed to be running JRE 4.7 apps on OS 6?  Is there a list of incompatible methods somewhere that I can reference?  In my quest to support all recent devices, I've been able to get by so far with only a JRE 4.5 and 4.7 build (one for keyboard devices and one for touch devices) I would hate to have to introduce yet another build just for the Torch.

:-(

 

~NN

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: OS 6 Torch build different than OS 5 build

I'm interested in restricting the Builds I have to do, so anything that means a 4.7 build won't work on the Torch is a worry.  Can you replicate the problem in standalone screen that we can then play with?