Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
New Contributor
Posts: 5
Registered: ‎08-13-2012
My Device: Blackberry6,Blackberry7,Blackberry10
My Carrier: all

Please help me in solving My Blackberry application issue

Hello Everyone

 

I have one project ... dont know on which platform it is developed and for which specific device it support but using this project i have to develop jar jad and code which shlould run on blackberry 6,7 and 10...what shlould i do .... i downloaded blackberry 7.0.1 plugins for eclipse ... few times it showed no error in the console...but the application did not run on the simulator....

 

Please reply and guide me with your valuable suggestions

 

Thank you

Developer
Posts: 206
Registered: ‎02-22-2011
My Device: BB TORCH & 9800
My Carrier: idea

Re: Please help me in solving My Blackberry application issue

Welcome to the forums,
You are saying "My BlackBerry application" and "dont know on which platform it is developed"?... make it clear are you having BlackBerry project..? ..
*****************************************************************************
* Give kudos when you like it
* Mark it as a solution if it fixes your issue
New Contributor
Posts: 5
Registered: ‎08-13-2012
My Device: Blackberry6,Blackberry7,Blackberry10
My Carrier: all

Re: Please help me in solving My Blackberry application issue

It was given by client ... he did not mentioned anything ....he just want blackberry built out of it....i have netbeans 5.5.1 and netbeans 6 but as the application is not running ....i doubt about the platform issue or even it could be because it is not developed for blackberry...i can give you the list of files generated by this platform....list of files in my project....
Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Please help me in solving My Blackberry application issue

You need to be aware that the only Java support on the BB 10 platform is Android. 

 

This means unfortunately there is no way you can develop a single Java source that will run on BB 6 BB 7 and BB 10. 

 

For the moment I think you should concentrate on getting it out the door for BB 6 and BB7. 

 

There is no official support for NetBeans so you are going to struggle to develop using the platform.  There are people who have published guides on doing this, you can search here or the Internet to find these.  But I'm not sure how current these are. 

 

The other thing to be aware of is that you can't just take a normal Java project and run it on BlackBerry - the Java that runs on BlackBerry is J2ME, which is really a subset of Java and in terms of functionality, is about Java 1.3 or 1.4.  So a load of standard Java things, like generics, just don't work.

 

So what would I do in your shoes?

 

1) I would find out more about the application you have been given, and figure out what it was written for, that will give you some idea of how difficult the job is you have.

 

2) I would also download the Eclipse plug-in and try your project out on that - that will tell you how much non standard stuff you have. 

 

Regarding OS 10, how you handle that will depend on what you find out above.

 

For further information on all the supported development environment, have a look here:

https://developer.blackberry.com/

New Contributor
Posts: 5
Registered: ‎08-13-2012
My Device: Blackberry6,Blackberry7,Blackberry10
My Carrier: all

Re: Please help me in solving My Blackberry application issue

thanks for your valuable information ..... i want your more help please  ...... how to crack the code or know the keys and get the job done ..... may you help me ....  also as i was not aware that android code is only supported on blackberry 10 platform....what are the other things i must know.....ofcourse run the code on netbeans is not as easy task but i found plugins for blackerry for netbeans platform.... i too have the blackberry eclipse

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Please help me in solving My Blackberry application issue

"how to crack the code or know the keys and get the job done "  This is new.  What do you mean?

 

I am not sure what you are really asking here.  Do you have the source for the application?

New Contributor
Posts: 5
Registered: ‎08-13-2012
My Device: Blackberry6,Blackberry7,Blackberry10
My Carrier: all

Re: Please help me in solving My Blackberry application issue

yes i have complete sourse code....by asking how to crack ...i mean how to start the code is completely new to me....the way it is designed and coded is completely different...moreover developed on different environment....by asking key ...i mean u must have faced this kind of issues..so wat was ur way technique...so i could execute it ... one more thing i want to come out of this dependency.....like i was not aware about the fact that android can only run on bb10...and what can be done for bb6 and bb7