Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 15
Registered: ‎07-01-2011
My Device: 8110
My Carrier: vodafone

Preprocessing is not working in blackberry eclipse plugin of Version: 2.0.0.201207181003?

Steps to reproduce

1) Write code in blackberry project as given below 

 

//#preprocessor
//#ifdef BlackBerrySDK6.0.0 | BlackBerrySDK7.0.0 | BlackBerrySDK7.1.0
package com.csam.mclient.context;

import net.rim.device.api.gps.LocationInfo;

/**
 * The implementation of VersionSpecificGPSStatusProvider for Blackberry JDE
 * 6.0, 7.0, 7.1
 * 
 *
 * @version 4.4
 * 
 */
public class BlackBerryGPSStatusProvider6 implements
		VersionSpecificGPSStatusProvider {

	public boolean isGPSEnabled() {
		// true if GPS is enabled on the device, false otherwise.
		return LocationInfo.isLocationOn();
	}

}
//#endif

2.) Set JRE version of blackberry project to 5.0.0

 

Actual Result


In blackberry  java plugin Version:  1.3.0.201102031007-19

This class is get preprocessed, and run an application successfuly.

In blackberry  java plugin Version:  2.0.0.201207181003

This clas is not get preprocessed and throws compilation error for LocationInfo class. and run process get terminated.

 

Accepted Result

In both version it should work same.

Highlighted
Contributor
Posts: 15
Registered: ‎07-01-2011
My Device: 8110
My Carrier: vodafone

Re: Preprocessing is not working in blackberry eclipse plugin of Version: 2.0.0.201207181003?

Adding to above,

What I have found in java plugin Version: 2.0.0.201207181003
1. Class which is having compilation error due JDE incompatibility does not get preprocessed (i.e. complication error still remains)
2 Class which is compatible across all JDE is not having above issue.

So my question is whether JDE specific pre-processing is no longer available in version above 1.3

If so kindly suggest a workaround.