Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 48
Registered: ‎05-26-2011
My Device: Bold 9700
My Carrier: Telkomsel

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

I think so. I email rim and they suggest the same things. Now waiting confirmation from BetaZone. But why you hope me to get exception with net_rim_cod_BBM Module not found? This exception occured when BBM 6 client not installed on device right? Don't pray that not good for me, my friend. I not wanna get any exception. Smiley Sad

Contributor
Posts: 14
Registered: ‎09-08-2011
My Device: Developer
My Carrier: Developer

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

Does the net.rim.device.api.ui.component.TextInputDialog class actually exist? I've searched through javadocs for the net.rim.device.api.ui.component and haven't been able to find a single bit of evidence that suggests this class exists. I've been sitting with this same issue. I've even tried to manually preverify the net_rim_bb_qm_platform.jar using JDE 6. I keep running into the same issue. Problem is that I want to integrate the library into an already existing project, so trying to follow the setup guide would pretty much mean restarting from scratch and redoing a lot of work that I've already done. So, does anyone know where I can find a version of the BBM SDK that doesn't try to reference a non-existent class?
Contributor
Posts: 48
Registered: ‎05-26-2011
My Device: Bold 9700
My Carrier: Telkomsel

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

The problem may be at intergration with the library. Don't copy the jar at your project and use "add external jar" instead of  "add jar" when configure build path at eclipse.

Contributor
Posts: 14
Registered: ‎09-08-2011
My Device: Developer
My Carrier: Developer

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

The problem is that I'm using Netbeans, not Eclipse. I've gotten it to include the library by adding it to the Ant classpath options in Netbeans. If I do this, then I can get it to compile without any problems, but when I try to run it I find that the BBM library wasn't included since it gives me a NoClassDef exception.
Contributor
Posts: 48
Registered: ‎05-26-2011
My Device: Bold 9700
My Carrier: Telkomsel

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

[ Edited ]

I'm not familiar with netBeans.

But for your issue, the net_rim_bb_qm_platform.jar is already exist if you have bbm 6.0 on device (you could check this at option > application), so if you include the library to your project, your application will reference to project jar when it should be reference to jar from bbm 6.0.

cmiiw.

Contributor
Posts: 14
Registered: ‎09-08-2011
My Device: Developer
My Carrier: Developer

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

Aha! The simulator I'm trying it on only has version 5 of BBM. Thank you. Smiley Happy
Contributor
Posts: 14
Registered: ‎09-08-2011
My Device: Developer
My Carrier: Developer

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

OK, I just tried it on a BlackBerry that does have BBM6 installed and I still get a NoClassDefFound error. Smiley Sad
Contributor
Posts: 14
Registered: ‎09-08-2011
My Device: Developer
My Carrier: Developer

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

Has anyone had any further luck or insight into this?
Highlighted
Contributor
Posts: 14
Registered: ‎09-08-2011
My Device: Developer
My Carrier: Developer

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

OK, now I've found something else that's really weird. I can include the library and build the app with no problems, but the moment I try to extend one of the classes (for example create a class that extends BBMPlatformApplication), then the build process fails at preverification and says it can't find the BBMPlatformApplication class.