Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Forums Advisor I
Posts: 501
Registered: ‎03-01-2013
My Device: BlackBerry Z10

Problem in debugging the application on blackberry device

Hi

I am running my code on blackberry device but when i run after second or third time,it will not update .And if i delete it and run it again, then it will not run.Nothing displays on the device.

Regular Contributor
Posts: 66
Registered: ‎08-28-2010
My Device: 9630

Re: Problem in debugging the application on blackberry device

When your doing debugging on your blackberry device then from eclipse properly stop the debug. do run again and again when your in debuggin application. once you stop debuging then later try again for it so your problem will resolve.

Forums Advisor I
Posts: 501
Registered: ‎03-01-2013
My Device: BlackBerry Z10

Re: Problem in debugging the application on blackberry device

Yes i am doing like this bt still i am not getting the updated result.

Right now i have deleted the icon from the device and if i am running the same app again.It will not display on device

Regular Contributor
Posts: 66
Registered: ‎08-28-2010
My Device: 9630

Re: Problem in debugging the application on blackberry device

remove your application again...power off your phone....remove battery and simcard.

 

Insert again your simcard and battery. power on your phone, and try to debug again and verify it show update changes in your application.

 

 

Regards,

Forums Advisor I
Posts: 501
Registered: ‎03-01-2013
My Device: BlackBerry Z10

Re: Problem in debugging the application on blackberry device

Still the code is not running.

No icon displayed on blackberry device.

I have removed the battery also.

Regular Contributor
Posts: 66
Registered: ‎08-28-2010
My Device: 9630

Re: Problem in debugging the application on blackberry device

Can you put your code here..................

 

 

or simply do crerate one new simple blackberry application and verify that it works in normal as well as in debug mode into blackberry device.

 

by doing this you will get idea that issue is in your code or in eclipse or in blackberry device.

 

Regards,

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Problem in debugging the application on blackberry device

I agree with the idea of creating a simple application and testing this on device. 

 

The one thing I would be careful of is to make sure the levels of software involved are compatible.  Which JRE are you developing using and which device  and OS level are you testing with?