Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
New Member
Posts: 2
Registered: ‎06-18-2012
My Device: Torch
My Carrier: IAM

Problem in installing plugin for eclipse

Hello

When i install plugin for eclipse , i get an ordinary eclipse without blackberry things (new blackberry projet , simulators .....) 

I download the full instaler from the blackberry website 

can someone help me plz

thx

New Member
Posts: 2
Registered: ‎06-18-2012
My Device: Torch
My Carrier: IAM

Re: Problem in installing plugin for eclipse

i have a 64 bits windows 

New Developer
Posts: 60
Registered: ‎09-23-2011
My Device: Blackberry
My Carrier: Blackberry Developer

Re: Problem in installing plugin for eclipse

Hello,

 

you have open eclipse.ini file and make some changes.

 

-startup
plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.1.R36x_v20100810
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
512m
--launcher.defaultAction
openFile
-vmargs
-Dosgi.framework.extensions=net.rim.ejde.preprocessing.hook
-Xms40m
-Xmx512M
-XX:MaxPermSize=512m

 

you can make changes in this file. you can also search the error message on google.

Highlighted
Regular Contributor
Posts: 75
Registered: ‎10-19-2011
My Device: Developer
My Carrier: verizon

Re: Problem in installing plugin for eclipse

For what it is worth, I just did a win7/64bit install over the weekend. I used the instructions from the following URL:

 

https://developer.blackberry.com/java/download/eclipse

 

I installed from the 'Developers without an Eclipse environment', i.e. I was putting the latest version of Eclipse on. Everthing went smoothly. I did have a bit of confustion when I tried to bring down old SDK's but MSohm cleared me up on it. NOTE: You must use 32 bit Java SDK!!!! (I used 6_31)

 

It all has been running great today.