Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 31
Registered: ‎02-03-2010
My Device: 8520
Accepted Solution

Problem packaging with the 1.5 Eclipse plug-in

Hi all,

 

after getting the new update for Blackberry plug-in I got strange error while packaging some of my projects:

An internal error occurred during: "Packaging projects...".
java.lang.NullPointerException

I thought that something went wrong while update, because other project made in the same way are OK, so I downloaded and installed the full 1.5 plug-in. I get again the same error with same projects. What could be the source of my problem? In the 1.3 plug-in all was working fine.

 

Thanks a lot

Eva Rezkova

Developer
Posts: 64
Registered: ‎09-10-2009
My Device: Z10, Bold 9700
My Carrier: O2 Germany

Re: Problem packaging with the 1.5 Eclipse plug-in

I am experiencing the same problem. Just updated the plugin and now I am unable to package my project because of that error.

Does anyone know a workaround?
----

My Twitter: @hendrik_dev
Developer
Posts: 31
Registered: ‎02-03-2010
My Device: 8520

Re: Problem packaging with the 1.5 Eclipse plug-in

Hi Hendrik,

 

do you have alternate entry points or custom icons in you project? Because these are the only differences I can see between the project I can compile and project I cannot.

 

Best Regards

Eva Rezkova

Developer
Posts: 64
Registered: ‎09-10-2009
My Device: Z10, Bold 9700
My Carrier: O2 Germany

Re: Problem packaging with the 1.5 Eclipse plug-in

The project has an application icon set and has an alternate entry point for autostart.
----

My Twitter: @hendrik_dev
Developer
Posts: 31
Registered: ‎02-03-2010
My Device: 8520

Re: Problem packaging with the 1.5 Eclipse plug-in

[ Edited ]

I tried to remove the icon and now I don't see any more this error, but I got another one while compiling:

C:\Users\PC\AppData\Local\Temp\rapc_610d7c16.dir\com\jamo\common\Log.class: Error!: Invalid class file: Incorrect classfile version
Packaging project MeuxAgent46 failed (took 5.716 seconds)

I made a clean of all project but still this remains. This moves me little bit forward.

Developer
Posts: 64
Registered: ‎09-10-2009
My Device: Z10, Bold 9700
My Carrier: O2 Germany

Re: Problem packaging with the 1.5 Eclipse plug-in

It's starting to get interesting: I am currently able to package my project without this error. Without having changed anything! I just tried it again after 5 minutes and now it works. What's going on here?

----

My Twitter: @hendrik_dev
Developer
Posts: 31
Registered: ‎02-03-2010
My Device: 8520

Re: Problem packaging with the 1.5 Eclipse plug-in

This I would know also. Because the file with error just above I'm using also in the other project (common) and there it get compiled without problems.

Developer
Posts: 16,997
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Problem packaging with the 1.5 Eclipse plug-in

I can confirm the issue, but am not able to reproduce it consistently.

Tried to package my project (untouched for a few weeks): NullPointer
Second try: Nullpointer.
Third try (without any change): Packaging completed.

I cannot find any logfile with meaningful errors or similar.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Posts: 16,997
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Problem packaging with the 1.5 Eclipse plug-in

found some details in the eclipse error log:

java.lang.NullPointerException
at net.rim.ejde.internal.H.P.A(RIMEIDE:295)
at net.rim.ejde.internal.H.P.<init>(RIMEIDE:2932)
at net.rim.ejde.internal.D.C.D(RIMEIDE:1537)
at net.rim.ejde.internal.D.C.B(RIMEIDE:1439)
at net.rim.ejde.internal.D.F.J(RIMEIDE:2774)
at net.rim.ejde.internal.D.F.G(RIMEIDE:1218)
at net.rim.ejde.internal.D.F.D(RIMEIDE:1760)
at net.rim.ejde.internal.D.F.D(RIMEIDE:383)
at net.rim.ejde.internal.D.A.run(RIMEIDE:1808)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1975)
at net.rim.ejde.internal.D.D.runInWorkspace(RIMEIDE:841)
at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Posts: 31
Registered: ‎02-03-2010
My Device: 8520

Re: Problem packaging with the 1.5 Eclipse plug-in

Now it's really good. I have SDK4.6-6.0 versions of the same project. The project are using common base and the never versions are overwriting some functions from the older one. If I compile for SDK4.6 I get preverification error for 5.0 classes. If I try to compile 5.0 I get the error in the original post (NullPointerException).

I really don't know what to check, the update behaves not really consistent.