Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 88
Registered: ‎09-25-2008
My Device: Not Specified
Accepted Solution

Problem with OTA and modules

Hi,

 

Im gettin this error when trying to installa OTA an app:

 

This application requires the following module, which is not installed: appNameLib.

 

I have a main project and a lib project.

 

I've putted the lib cod on the same folder, with the main projects cods (extracting from .zip) and jad.

 

Its strange, because it works on simulator.

 

Thanks in advance.

Highlighted
Developer
Posts: 17,019
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Problem with OTA and modules

did you add the cod files descriptor to the jad file?

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Posts: 88
Registered: ‎09-25-2008
My Device: Not Specified

Re: Problem with OTA and modules

[ Edited ]

How can I do that?  I just delete the jad and made a rebuild, so jad was created again.

 

 

Thanks.

Developer
Posts: 17,019
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Problem with OTA and modules

see my post here:

http://supportforums.blackberry.com/t5/Java-Development/Adding-a-Library/td-p/414941

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Posts: 88
Registered: ‎09-25-2008
My Device: Not Specified

Re: Problem with OTA and modules

Thank you very much, Simon. It worked.