Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
Posts: 54
Registered: ‎10-07-2008
My Device: Not Specified

Problem with breakpoints while debugging

Hi,

 

Thanks in advance for your kind help.


I have a problem with breakpoints.

Im using Netbeans 6.1 with mobility pack and I´m developing a Midlet for BlackBerry. I´m using the BB JDE 4.2 to compile the midlet .jar to .cod


The IDE does not allow me to insert breakpoints in code generated by visual designer. I place breakpoints in my custom code and does not hit that breaks, I see the console of the IDE while debugging and says the brakpoints where successfully submitted.

 

Debugging was working fine, suddenly this happened, I don´t remember changing any configuration.

 

I clean the simulator (int the simulator folder, run the clean.bat) and still not working.


I cannot debug the APP!!

Regards! Wink

New Developer
Posts: 54
Registered: ‎10-07-2008
My Device: Not Specified

Re: Problem with breakpoints while debugging

[ Edited ]

Hi,

 

I found this error while debugging:

 

 

debug: Copying 4 files to C:\Program Files\Research In Motion\BlackBerry JDE 4.2.0\simulator Copying D:\TRAVX\BlackBerry\BlackBerryTEx\BlackBerryTEx\dist\BlackBerryTEx.cso to C:\Program Files\Research In Motion\BlackBerry JDE 4.2.0\simulator\BlackBerryTEx.cso Copying D:\TRAVX\BlackBerry\BlackBerryTEx\BlackBerryTEx\dist\BlackBerryTEx.jad to C:\Program Files\Research In Motion\BlackBerry JDE 4.2.0\simulator\BlackBerryTEx.jad Copying D:\TRAVX\BlackBerry\BlackBerryTEx\BlackBerryTEx\dist\BlackBerryTEx.cod to C:\Program Files\Research In Motion\BlackBerry JDE 4.2.0\simulator\BlackBerryTEx.cod Copying D:\TRAVX\BlackBerry\BlackBerryTEx\BlackBerryTEx\dist\BlackBerryTEx.debug to C:\Program Files\Research In Motion\BlackBerry JDE 4.2.0\simulator\BlackBerryTEx.debug java.lang.NumberFormatException: For input string: "1 " at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48) at java.lang.Integer.parseInt(Integer.java:456) at java.lang.Integer.parseInt(Integer.java:497) at net.rim.ide.IDEProperties.getIntProperty(IDEProperties.java:345) at net.rim.ide.IDEProperties.getBoolProperty(IDEProperties.java:404) at net.rim.ide.SimulatorOptions.buildComponents(SimulatorOptions.java:440) at net.rim.ide.JDWPUI$c.<init>(JDWPUI.java:144) at net.rim.ide.JDWPUI.startUI(JDWPUI.java:388) at net.rim.ide.JDWP.init(JDWP.java:67) at net.rim.ide.JDWP.main(JDWP.java:57) nbdebug: Adding 777 second for debugger timeout KdpDebugTask connecting to debugger 1 .. Attached JPDA debugger to localhost:8000

 


 

 

 

I investigated a little what is it about, is the JDWP that wires the remote debugging.  I don´t know what is happening. Yesterday I was working so fine and now I´m stuck Smiley Sad

 

Thanks in advance for your help!

Message Edited by ArthurKnight on 11-12-2008 06:58 PM
Highlighted
New Developer
Posts: 54
Registered: ‎10-07-2008
My Device: Not Specified

Re: Problem with breakpoints while debugging

Hi,

 

I asked for support in Netbeans bugs registration and they responded to me:

 

http://www.netbeans.org/issues/show_bug.cgi?id=153099

User psuchomel changed the following:

               What    |Old value                 |New value
==============================

==================================================
       Target milestone|TBD                       |future
--------------------------------------------------------------------------------

------- Additional comments from psuchomel@netbeans.org Thu Nov 13 09:14:06 +0000 2008 -------
This is likely some problem in RIM if you see at net.rim.ide.JDWP.main(JDWP.java:57). JDWP.jar is NetBeans, this is some
RIM core library. Please note, RIM is not officially supported platform, so I am very limited to give you more advices
or help. Strongly recommend to ask about this specific issue on RIM related mailing list.

 

 

The problem is in the  net.rim.ide.JDWP 

 

Can somebody from RIM helps me please? Smiley Happy

 

Thanks in advance!