Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Visitor
Posts: 1
Registered: ‎06-27-2012
My Device: 9900
My Carrier: Wind

Problem with signature by using SignatureTool.jar

Hi all,

 

I have a problem with the signature of my application.

 

I'm working on Eclips IDE, Fedora os.

 

I have a main projetc (ProjectA) that have to include one other projects (ProjectB).

 

ProjectB includes another project (ProjectC)

 

So I start in this way:

 

PREVERIFY PROJECT B AND PROJECT C

 

./preverify -classpath  ...../net_rim_api.jar ...../projectB.jar

./preverify -classpath  ...../net_rim_api.jar ...../projectC.jar

 

Then I have to use RAPC

 

java -jar $SDK/bin/rapc.jar import=.../net_rim_api.jar /home/adriano/WTK2.5.2/bin/output/projectC.jar \
codename=importedProject.cod

So I have importedProject.cod, and I have to sign it

 

java -jar SignatureTool.jar importedProject.cod 

 

The frame I obtain make a list of 5 elements.

 

http://tinypic.com/r/2rntvs4/6

 

As you can see, the first 3 elements are signed, the last 2 not require signature. Signer IDs are RRT - RBB - RCR - 3 - RCI.

 

So i put the importedProject.cod into my project, and also I copy the generated importedProject.jar file (adding into it importedProject.cso and importedProject.cod).

 

Now i have to sign my main project. But when I try to sign it, this is the result:

 

http://tinypic.com/r/w2hgl0/6

 

As you can see, cod files with 3's signer ID are always not registered, RCR, RBB and RRT are ok, RCI is not required.

 

So, when I run my app, it does not start and show me a popup error message: "Error starting ProjectA: Module 'ProjectA-20' has verification error 1715 at offest 0003 (codfile version 78)".

 

I hope I explain well my situation.

 

How can I sign also others cod files, with signer id = 3?

 

TY in advance and BR,

 

Adriano.

Highlighted
Developer
Posts: 17,012
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Problem with signature by using SignatureTool.jar

welcome to the support forums.

this error message usually means that a used library cannot be found.

you can do two things to resolve that:
- add only the jar file to the project and mark it as "export" in the build properties
- add only the jar file to the project and add the cod file to the release (by adding it in the alx and jad files)

usually the first approach should work and is easier to maintain, unless you want the lib to be installed separately.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter