Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 38
Registered: ‎03-18-2010
My Device: 9000
My Carrier: Telekom.de/Vodafone.de
Accepted Solution

Problems at downloading additional BB JRE for Eclipse JDE Plugin

Hi,

 

I've already posted my problem in another thread but I didn't get any answers. As this is very important for me, I wanted to try with a new thread.

 

I've downloaded the BlackBerry JDE Plugin for Eclipse and now I've tried to download additional BB JREs. So I've added the URL http://www.blackberry.com/go/eclipseUpdate/3.5/java to the repositories. When trying to Download the "JRE 5.0.0" I get prompted to input a Username and Password. This I've tried many times with the Username and Password of the BB Developer Zone, but it doesn't work. It always tells me, that the login-information is wrong. What could be the problem? Do I have to use other login information or do I have to register somewhere else?

 

Thanks in advance for your answer!

 

Regards

jtr87

Super Contributor
Posts: 398
Registered: ‎01-12-2011
My Device: Q10
My Carrier: Fido

Re: Problems at downloading additional BB JRE for Eclipse JDE Plugin

[ Edited ]

I've always used my BB Developer password without any problems. However it was slow to download anything through Eclipse, sometimes it would hang at 40% for half an hour then suddenly come back to life.

 

Also, are you sure your password is correct? I mean it seems like a stupid question but I have been auto signed in to BB Developer site since I first registered, and never having to type in my password may cause me to forget.

Highlighted
Contributor
Posts: 38
Registered: ‎03-18-2010
My Device: 9000
My Carrier: Telekom.de/Vodafone.de

Re: Problems at downloading additional BB JRE for Eclipse JDE Plugin

Hi,

 

thanks for your answer. Yes, I'm sure that my password is correct. I've even typed it into a textfile and copied it into the textbox. I also changed the password and then tried to log in with the new one and it always tells me, that the password is wrong. Further I've also registered a new account with another E-Mail adress but this also didn't help.

 

I don't have any idea, why this doesn't work.

 

Regards!

jtr87

Developer
Posts: 19
Registered: ‎04-06-2011
My Device: Storm 9500
My Carrier: Vodaphone

Re: Problems at downloading additional BB JRE for Eclipse JDE Plugin

I had a problem with my password not working in one portion of the BB site whilst it worked elsewhere I don't know if I got them mixed up but I reset my password on the Blackberry Developer site and I've been fine since.

Thanks,

Mark.
Developer
Posts: 19
Registered: ‎04-06-2011
My Device: Storm 9500
My Carrier: Vodaphone

Re: Problems at downloading additional BB JRE for Eclipse JDE Plugin

OK, I just went to Help -> Install New Software and punched in the URL you supplied which listed Blackberry Java SDK versions:

 

 

  • 5.0.0.25
  • 4.7.0.57
  • 4.6.1.49
  • 4.6.0.23
  • 4.5.0.28
Note, that was SDK's not JRE's.  If you have the latest eclipse plugin then you would already have the 5.0 and 6.0 JRE's since I have without installing anything but the plugin from the BB website itself (not via the install software in eclipse).

 

Thanks,

Mark.
Contributor
Posts: 38
Registered: ‎03-18-2010
My Device: 9000
My Carrier: Telekom.de/Vodafone.de

Re: Problems at downloading additional BB JRE for Eclipse JDE Plugin

Hi,

 

thanks again for your answers. So I've tried again and reset my password, but it still doesn't work. As mentioned above I've even registered a new account using another mail-adress but theres always the same problem. I also tried different computers.

 

@netniv

 

I've installed version 1.3 of the eclipse plugin but there's only JRE 6.0.0 in the dropdown box at creating a new project an whenn I install a simulator using software version 5.0.0 (BB 9000) the application doesn't run. (The application was written using SDK 4.5 so there should be no problem with missing features)

 

Is there any other way to get the JRE insted of using the download function of eclipse?

 

Thanks in advance!

 

jtr87

Developer
Posts: 19
Registered: ‎04-06-2011
My Device: Storm 9500
My Carrier: Vodaphone

Re: Problems at downloading additional BB JRE for Eclipse JDE Plugin

[ Edited ]

I don't know about when you are creating a project but you can certain try to change it afterwards by going into project properties:

 

 

  1. Right click on the project and properties)
  2. Click on Java Build Path
  3. Click on Libraries tab on the right hand side
  4. Add LIbrary
  5. JRE System Library
  6. Alternate JRE
Now, you would think that it was listed there but when I checked Installed JRE's, I realised that the reason I have both 6.0 and 5.0 is because I recently downloaded an older version of eclipse and installed it to a different folder.
The version I downloaded was BlackBerry_JDE_PluginFull_1.1.2.201003212304-12 which I did to attempt to get working with the Storm.

So, I think that I was wrong earlier in my assumption that I just had the latest version as I'd forgotten this brief test to get things working and maybe this is the real reason why I have both.
If you do download and install that version of the simulator, I would recommend installing to a different folder than your latest v1.3 eclipse by either renaming the existing one (which I did) and installing to the default path, or using an alternate path.  The reason I did the former is so that I can rename them both to keep the current working version in c:\eclipse which is the default.

 

Thanks,

Mark.
Contributor
Posts: 38
Registered: ‎03-18-2010
My Device: 9000
My Carrier: Telekom.de/Vodafone.de

Re: Problems at downloading additional BB JRE for Eclipse JDE Plugin

Hi,

 

thanks again for your answer. I've solved the problem Smiley Happy The URL I used was wrong. I have found the URL in another thread here and it seems that it is just out of date. Until now I used the URL

 

http://www.blackberry.com/go/eclipseUpdate/3.5/java

 

to download further JRE's but for Version 1.3 the right URL is

 

http://www.blackberry.com/go/eclipseUpdate/3.6/java

 

 

Thanks again for your help!

 

Regards

Roland

New Contributor
Posts: 8
Registered: ‎04-11-2011
My Device: none
My Carrier: n/a

Re: Problems at downloading additional BB JRE for Eclipse JDE Plugin

I have tried both updae urls, neither one works for me.

 

The downloader starts and never gets past about 33% - this has been going on for a few days now.

Contributor
Posts: 13
Registered: ‎04-12-2011
My Device: BlackBerry Curve 8500 Series
My Carrier: O2

Re: Problems at downloading additional BB JRE for Eclipse JDE Plugin

I'm also having a problem with this, but I can't even get to the download stage.

 

When I go to Help > Install New Software and add the URL above (I have tried both) I get an error message saying 'No software site found'??