Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Developer
Posts: 41
Registered: ‎09-27-2010
My Device: 8900 Curve

Radio buttons don't work in BrowserField (NAVIGATION_MODE_NODE, OS 6.0)

[ Edited ]

Hello guys,

 

[OS 6.0, BrowserField, NAVIGATION_MODE_NODE]

 

I have a strange problem here...

I must develop an application (6.0) which will use the BrowserField for rendering some HTML files. It will use NAVIGATION_MODE_NODE, the keypad will be used to navigate from a focusable element to another.

 

I've created a HTML test file here http://dl.dropbox.com/u/1441583/TestPage.html with some input fields.

All of them are working fine, only the radio buttons don't work.

- If I don't add "checked="checked"" into a radio button (from a group - all radio buttons are unchecked), the group is skipped (no radio button from the group receives the focus);

- If I check a radio button from a group, only this checked radio button will be focused, but still I cannot select another radio button from the group - the rest of the radio buttons from the group are skipped.

 

The checkboxes are working fine...

final BrowserFieldConfig browserConfig = new BrowserFieldConfig();

browserConfig.setProperty(BrowserFieldConfig.JAVASCRIPT_ENABLED, Boolean.TRUE);

browserConfig.setProperty(BrowserFieldConfig.ENABLE_COOKIES, Boolean.TRUE);

browserConfig.setProperty(BrowserFieldConfig.ALLOW_CS_XHR, Boolean.TRUE);

browserConfig.setProperty(BrowserFieldConfig.NAVIGATION_MODE, BrowserFieldConfig.NAVIGATION_MODE_NODE);

 

I'm using 9800 and 9700 emulators (I don't have a 6.0 device).

I've tested with www.google.com -> Settings (there are some radio buttons in that page), and the same: I cannot select another radio button from a group...

 

Do you have a hint for that?

 

Thank you very much,

Tibi.

 

Developer
Posts: 41
Registered: ‎09-27-2010
My Device: 8900 Curve

Re: Radio buttons don't work in BrowserField (NAVIGATION_MODE_NODE, OS 6.0)

Hi,

 

Somebody tested on a real device, and this wrong behavior is present too.

I've tried to find something related to this issue over internet, but I didn't find.

It's a "known issue", or can I do something to fix that?

It's quite urgent...

 

Thanks.

 

Developer
Posts: 41
Registered: ‎09-27-2010
My Device: 8900 Curve

Re: Radio buttons don't work in BrowserField (NAVIGATION_MODE_NODE, OS 6.0)

Hi,

 

I've tried on a BB 9780, and the combo-box doesn't work!

So, in NAVIGATION_MODE_NODE mode, the radio buttons and combo boxes don't work?

On some 6.0 emulators the combo boxes are working.

Do you have any clue?

 

Thanks.

Highlighted
Developer
Posts: 88
Registered: ‎09-25-2008
My Device: Not Specified

Re: Radio buttons don't work in BrowserField (NAVIGATION_MODE_NODE, OS 6.0)

I have exactly the same problem.

 

Any solution?