Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 59
Registered: ‎06-15-2012
My Device: 9800
My Carrier: XZY

Regarding Wifi Problem(challenging Work)

Hey Good Morning Every one,

 

                      I have one problem, I have application in which I am using http post method to send data to the server,

but the problem is some time is working and some time it is giving error to me.  The error I am getting in Blackberry Log.  Error Message :" Error in post http request for URL http://w3school.com/asp/demo_simpleform.asp:local connection timed out after -120000"-

 

I have check wifi connection  I am getting message is wifi is connected. But why some time is working. 

 

Is it simulator problem , I am stuck please help me.

Thanks in advance.

Developer
Posts: 16,987
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Regarding Wifi Problem(challenging Work)

120 seconds is the standard timeout, you can reduce it to have easier error handling, using http://www.blackberry.com/developers/docs/7.1.0api/net/rim/device/api/io/transport/ConnectionFactory... for example.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Posts: 59
Registered: ‎06-15-2012
My Device: 9800
My Carrier: XZY

Re: Regarding Wifi Problem(challenging Work)

 

Hey Semon  thanks for 4 replay. i think the problem is wifi in the simulator is not working properly. Before requesting to the server I am checking the wifi connection that I getting true. But when i press the request button that time. the small icon should show on right corner of the simulator(which indicate the internet connection process) it is not happening.

And when I getting the output that time internet indication process is happening.(it is funny) and make me crazy.

 

Please any clue will be appreciate.

 

Highlighted
Developer
Posts: 16,987
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Regarding Wifi Problem(challenging Work)

test on a real device, then
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter