Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Regular Contributor
Posts: 52
Registered: ‎11-29-2010
My Device: Blackberry 9700

SQL-lite in Blackberry 4.5

Hi,

  I am developing a messenger application for blackberry version 4.2 or later.  Since I have a large amount of data to be stored, I prefer to user SQLite as the database. In documents it is mentioned that Blackberry Version5.0 and later provides built in SQLlite.  IS there anyway to use SQLite in version 4.2 or later?  Please reply as soon as possible.

Contributor
Posts: 14
Registered: ‎10-21-2010
My Device: 9520
My Carrier: no

Re: SQL-lite in Blackberry 4.5

Hello Dear,

 

 

 

            Use sqlite database storage in sdCard of mobile then use large database size for your device and don't use device memory for large sqlite database other wise your application is not usable for your device..................

 

.....

 

Manoj Kumar Baghela

Regular Contributor
Posts: 52
Registered: ‎11-29-2010
My Device: Blackberry 9700

Re: SQL-lite in Blackberry 4.5

Can we use SQLlite in Blackberry 4.2 or 4.5. If yes please let me know how to do that.

Regular Contributor
Posts: 61
Registered: ‎08-11-2010
My Device: Not Specified

Re: SQL-lite in Blackberry 4.5

to my knowledge, sql-lite cannot be used with 4.5 or lower. U may install it on your card and use which i haven't tried. But another fact is, 4.5 and lower doesn't allow you to install softwares on the card. So I think you are left only with the persistent store option.

Regular Contributor
Posts: 52
Registered: ‎11-29-2010
My Device: Blackberry 9700

Re: SQL-lite in Blackberry 4.5

thank u koolshiva,

 I decided to use persistent storage