Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

New Contributor
Posts: 4
Registered: ‎03-09-2011
My Device: Not Specified
Accepted Solution

Sample applications not working.



i am trying to launch the given sample/demo applications to simulator.

Most of them are giving errors.



For HTTPDemo project, i get this error

"Error starting HTTPDemo Class. 'net.rim.device.api.command.Comman' not found"


For SockerDemo Project - Same error.


For SMSDemo

"Error starting SMSDemo Class. 'net.rim.device.api.command.CommandHandler' not found"


I'm running Simulator version - 8900 - and using eclipse plugin.


I tried searching the issue, some are saying that this "command class" is available on 6.0 version of simulator only, so it wont work on this one and to use the samples of 4.5 instead.

But I couldn't find sample examples for 4.5.


Any help would be appreciated.

Posts: 17,006
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Sample applications not working.


welcome to the support forum.


you find the samples in this folder, starting from your eclipse installation (modify the number for the JRE version):



as you work with 5.0 i would suggest you use the 5.0 samples.

another option would be to change the JRE of eclipse to 6.0, depends on the target of your project.

feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
New Contributor
Posts: 4
Registered: ‎03-09-2011
My Device: Not Specified

Re: Sample applications not working.

Thanks. Kudos. Done :-)

New Contributor
Posts: 2
Registered: ‎06-12-2011
My Device: curve 9800
My Carrier: movi star

Re: Sample applications not working.



I have the same problem, i have jre1.6, the class Command exist in it package, I have modified compilation settings from 1.4 to 1.6 but it doesn't work. I'm trying with  simulator bold -9700 ,


can someone help me!!?