Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Posts: 52
Registered: ‎07-17-2008
My Device: Not Specified

Sibbling COD files are not getting downloaded

[ Edited ]

Our App seems to have graduated above 64k limit.  Now there are two COD files myApp.cod and myApp-1.cod that get generated.


Majority of the times the OTA installtion goes very well.   Rest of the times though the app gets installed, but when the user tries to start the app, an error shows up stating myApp-1.cod not found.


Is this a known issue? Is there any setting or something needed on the web server to ensure that both CODs get downloaded?


This is my JAD file:



Manifest-Version: 1.0
MIDlet-Jar-Size: 119019
RIM-MIDlet-Icon-1-2: img/myApp.png
MicroEdition-Configuration: CLDC-1.1
MIDlet-Jar-URL: myApp.jar
RIM-MIDlet-Icon-1-1: img/myApp.png
RIM-COD-Module-Dependencies: net_rim_cldc,net_rim_bbapi_phone,net_rim_bbapi_mailv2,net_rim_bb_framework_api,net_rim_os,net_rim_bbapi_invoke
RIM-COD-URL-1: myApp-1.cod
RIM-COD-SHA1-1: 62 87 ea 3c 79 b1 94 3e 2f af c5 e7 da 58 42 a6 29 d6 af be
RIM-MIDlet-Flags-2: 3
RIM-MIDlet-Flags-1: 0
RIM-COD-Size-1: 44460
RIM-COD-Module-Name: myApp
RIM-COD-Size: 37060
MIDlet-Name: myApp
RIM-COD-Creation-Time: 1219777941
MIDlet-2: ,img/myApp.png,autostartup
MIDlet-1: my App,img/myApp.png,
RIM-COD-URL: myApp.cod
MIDlet-Description: my App

RIM-COD-SHA1: 0d 35 50 74 ef 4d 98 bb ac 47 ae 2c fd 5e 56 2b 17 d7 5a 20
MicroEdition-Profile: MIDP-2.0
MIDlet-Vendor: theCompany
RIM-MIDlet-Icon-Count-1: 1

Message Edited by akirekadu on 08-27-2008 05:05 PM
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Sibling COD files are not getting downloaded

I think you will find that if you use the BlackBerry browser (especially later versions), it can cope with sibling cod files, whereas WAP, Internet Browser or earlier versions of the Blackberry browser can not.  No doubt Mark Sohm will put this statement right when he next looks.


Did a quick search on sibling in this forum and found the following that I think might help:



I also suggest you review the "Packaging and distributing BlackBerry Java Applications" of the Development Guide.  There is some good information in there about sibling files and how to handle them

BlackBerry Development Advisor
Posts: 15,693
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Sibling COD files are not getting downloaded

Peter is correct and this link provides the details.


What Is - The file size limit for wireless downloads
Article Number: DB-00015



However, by listing all of your sibling cods in the JAD file you should support all browsers.  Have you extracted the 2 cod files to your web server?  Or do you just have the main cod file there?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Posts: 52
Registered: ‎07-17-2008
My Device: Not Specified

Re: Sibling COD files are not getting downloaded

[ Edited ]

I do not think the issue we are facing is related to what is discussed in those links.  Something different.  In our case, we do unpack the parent COD.  The BlackBerry is downloading the myApp.cod, but not myApp-1.cod.  Sounds like some sort of OS bug to me.  Checking if there is any workaround.


Here are the contents of my webserver directory (number agains each file is the size in bytes):


LogFile.txt        109
myApp-1.cod     30908
myApp.alx    464
myApp.cod    46908
myApp.csl    60
myApp.jad    989
myApp.jar    111780
myApp.png    3232

Message Edited by akirekadu on 08-29-2008 09:59 AM
Message Edited by akirekadu on 08-29-2008 10:00 AM
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Sibling COD files are not getting downloaded

Seems to be a mismatch in the cod names given in the original jad and description (myApp.cod etc), with the listing from the directory (myBoxToneInsight.cod).  Would it be possible to see the jad associated with the myBoxToneInsight cods?  Can you tell us what level of OS is on the device(s) that you see the problem with?  And was the -2 in myApp-2.cod a typo?


You might like to try deleting the jad and then rebuilding the app to make sure you get a current jad built.  This is assuming that the jad is built by the JDE - in which case, which level JDE are you using? 

Posts: 52
Registered: ‎07-17-2008
My Device: Not Specified

Re: Sibling COD files are not getting downloaded

[ Edited ]

peter,  sorry about the confusion.  there were several errors in my last reply. 

I have created a new thread to clear the confusion and to keep all the relevant information in one place:





Message Edited by akirekadu on 08-29-2008 11:00 AM