Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Posts: 47
Registered: ‎05-03-2011
My Device: BlackBerry Torch 9800
My Carrier: Vodafone

Signed all CSI files but still getting error


I was required to sign my application to blackbery even when it only worked a 2day ago  i dont know why but i signed up and i just registered my application on Eclipse(RRT,RCR and RBB files) but when i fun the application i still get the same runtime error and it says my application is trying to access secure Api's i dont undastand can someone please tell me what to do 



BlackBerry Development Advisor
Posts: 15,874
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Signed all CSI files but still getting error

Can you post a screenshot of SignatureTool open, showing what has been signed in your application?


You can also extract the signing error from the event log to see what key is causing the error.  To do so use the following command:


javaloader -u eventlog > mylog.txt


Then look for a line that says no sig from....  where your application is referenced.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.