Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 40
Registered: ‎03-29-2009
My Device: Storm 9550
My Carrier: AT&T

Re: Simulating GPS in simulator does not work

Well, if this was fixed in a 4.7.0.70 simulator, then it got unfixed pretty quickly.

 

I'm running the 4.7.0.148 Storm simulators, or the 4.7.1.40 Tour 9630 simulators.  In both cases, I see the maps app load map backgrounds, but it can never resolve its position.  It always stays stuck on "Searching for satellites".  Always. 

 

I have the MDS simulator running, I've enabled GPS in the device options (Location ON), and have defined a custom lat/long in the GPS Location menu of the simulator.

 

I have also run this with a Bold 4.6 simulator, and it doesn't work.  There must be something that we have to do to enable this, that people aren't explicitly telling us.

 

My app programmatically queries the device's location, and it DOES properly receive the location that I defined in the GPS Location menu.  But, somehow, the Maps app can't retrieve this location.  Why?

 

I'm trying to integrate my app with Maps, but this is making it impossible.  Please address this, RIM.

Highlighted
Developer
Posts: 40
Registered: ‎03-29-2009
My Device: Storm 9550
My Carrier: AT&T

Re: Simulating GPS in simulator does not work

As a follow-up, I am able to get this to work in the 9500-Vodafone 4.7.0.148 simulator.  So, it doesn't work for me in the 9530-Verizon simulator at the exact same OS level (4.7.0.148), but it does work in the 9500 Vodafone.