Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

New Developer
Posts: 28
Registered: ‎08-19-2008
My Device: Not Specified

Simulator crash?

[ Edited ]

I'm writing application on JDE 4.3, and when I test the application, it doesn't load to the simulator. And I saw a log file "8120.xml-(2008-08-26).log", it shows following messages at the end of the file.


[19:04:30:821] [AppInfoExtractor] [0x000017a4] [DeviceAppInfoExtractor.cpp:613] Failed to query package net.rim.blackberry.spellcheck.
[19:04:30:821] [AppInfoExtractor] [0x000017a4] [DeviceAppInfoExtractor.cpp:613] Failed to query package net.rim.java.browser.javascript.
[19:04:30:821] [AppInfoExtractor] [0x000017a4] [DeviceAppInfoExtractor.cpp:133] Package "net.rim.java.browser" is missing module "C:\Program Files\Research In Motion\BlackBerry JDE 4.3.0\simulator\Java\net_rim_bb_rich_email.cod".


Also, there are some ".dmp" files (8120-xx.dmp).


I've tried to run "clean.bat" to clean the simulator, but it still same!


What happen and what should I do?



Message Edited by vinho on 08-26-2008 07:17 AM
BlackBerry Development Advisor
Posts: 15,877
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Simulator crash?

Does the BlackBerry Simulator start up to the home screen?  If not, what error do you see there?


When you say your application does not load, what do you mean?  Is no icon shown or are you unable to launch the application?  If it is the latter, what error or exception do you receive when you try to launch your application?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.