Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
Posts: 7
Registered: ‎08-08-2009
My Device: Not Specified

Re: Strange build error after code checked into Subversion

Another way to fix this (steps are for 3.4.1 Eclipse):

 

Project menu, Properties item

Java Build Path

Under your [whatever]/src item click on "Excluded", then the "Edit" button

Under  "Exclusion Patterns", add

 

**/.svn/**

 

Finish, OK

New Developer
Posts: 5
Registered: ‎09-29-2009
My Device: Not Specified

Re: Strange build error after code checked into Subversion

Using the Java Build Path to exclude files doesn't work for Resource files.

New Developer
Posts: 26
Registered: ‎10-23-2009
My Device: Not Specified

Re: Strange build error after code checked into Subversion

I use Subclipse and I don't experience this problem.

 

http://subclipse.tigris.org

 

New Developer
Posts: 5
Registered: ‎09-29-2009
My Device: Not Specified

Re: Strange build error after code checked into Subversion

Does your project have resources files? .rrh and .rrc files?

New Developer
Posts: 26
Registered: ‎10-23-2009
My Device: Not Specified

Re: Strange build error after code checked into Subversion

mfaulise said:

> Does your project have resources files? .rrh and .rrc files?

 

No I don't have any .rrh and .rrc files in my project.

 

 

New Developer
Posts: 6
Registered: ‎10-27-2009
My Device: Not Specified

Re: Strange build error after code checked into Subversion

Using the exclude (**/.svn/**, and other variations) pattern,  did not work for me. This problem comes up for me periodically and I simply check "Build automatically" and immediatly uncheck it and the problem goes away. Kind of strange but it works.

New Contributor
Posts: 2
Registered: ‎02-21-2010
My Device: Storm
My Carrier: Verizon

Re: Strange build error after code checked into Subversion

solution by tylerc also worked for me.

 

"Not sure if other people are experiencing this problem. The solution I found was to turn off auto building (if its already off turn it on and turn it off again). Its the last menu item under projects. To build select "build active blackberry configuration" under the projects menu. Seems to work for me."

Developer
Posts: 77
Registered: ‎06-03-2009
My Device: Not Specified

Re: Strange build error after code checked into Subversion

[ Edited ]

I have  just started to use toroise svn , so i copied my project folders to another folder and made svn monitor those folders, now i too have this same error.


Any solution to that already?

New Developer
New Developer
Posts: 151
Registered: ‎01-05-2010
My Device: dev alpha c (bb10)
My Carrier: www.rzr.online.fr

Re: Strange build error after code checked into Subversion

had this message (i use git not svn but does it matters? )


Errors occurred during the build.
Errors running builder 'Java Builder' on project '${PROJECT}'.
java.lang.NullPointerException

 

And then :

 

 

Warning!: No entry points found
Warning!: No definition found for exported static routine: .main(String[])

 

Related:

http://supportforums.blackberry.com/t5/Java-Development/Errors-running-builder-BlackBerry-Resources-...