Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Supported versions of Java for different BlackBerry JDE versions

by Retired on ‎02-17-2010 02:12 PM - edited on ‎01-25-2012 03:26 PM by Retired (6,324 Views)

Summary

 

This article applies to the following:

 

  • BlackBerry® Java® Development Environment (BlackBerry JDE)
  • BlackBerry® Java Plug-in for Eclipse®

Description

 

The following table outlines the supported Java software development kit (SDK)/Java Development Kit (JDK) versions for different versions of the BlackBerry JDE software.  The 32 bit version of JDK is required in all cases.  The 64 bit JDK is not supported.


BlackBerry JDE version (standalone and BlackBerry Java Plug-in for Eclipse) Java SDK/JDK version 
3.6 1.4
3.7 1.4
4.0 1.4
4.0.2 1.4
4.1 1.5
4.2 1.5
4.2.1 1.5 and 1.6
4.3.0 1.5 and 1.6
4.5.0 1.6
4.6.0 1.6
4.6.1 1.6
4.7.0 1.6
5.0 1.6
6.0 1.6
7.0 1.6
7.1 1.6 or 1.7
Users Online
Currently online: 27 members 891 guests
Please welcome our newest community members: