Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 50
Registered: ‎09-01-2009
My Device: Not Specified
Accepted Solution

The specified module was rejected by the device and cannot be loaded

Hi

 

I have develop one application it works fine on my simulator.....but when i try to run it on device it gives me error 

"The specified module was rejected by the device and cannot be loaded"

 

I am using Blackberry JDE 5.0. Can you please help me? its really urgent.

 

Thanks

Gunjan

Developer
Posts: 455
Registered: ‎01-14-2009
My Device: Apple iPhone 3GS 16GB

Re: The specified module was rejected by the device and cannot be loaded

which device and what os version are you running the application on?

Developer
Posts: 50
Registered: ‎09-01-2009
My Device: Not Specified

Re: The specified module was rejected by the device and cannot be loaded

Hi

 

Thanks for your reply.

 

Blackberry Strom....it was working on same device some time back....but when i try to load it again after some minor changes...it is creating problem

 

Thanks

Gunjan

Highlighted
Developer
Posts: 455
Registered: ‎01-14-2009
My Device: Apple iPhone 3GS 16GB

Re: The specified module was rejected by the device and cannot be loaded

i assume storm is running OS 4.7 . In that case you need to compile the application in any  JDE <=4.7 . There is a general rule that The JDE version should be less than or equal to the OS version.

 

 

Contributor
Posts: 47
Registered: ‎08-26-2011
My Device: dsa
My Carrier: programmer

Re: The specified module was rejected by the device and cannot be loaded

i got this error and cannot find any way to solve.
I've got a midlet project -> jde 6.0.0
and a torch with  6.1bundle 579

javaloader drop the same errror Smiley Sad
Any idea? 

New Contributor
Posts: 4
Registered: ‎02-27-2014
My Device: device version : 4.6.1.310 (platform 4.2.0.127) 8900 Smart Phone(Edge Wifi)
My Carrier: ETISALAT

Re: The specified module was rejected by the device and cannot be loaded

I am using webworks SDK and trying to deploy  Hello World application to the device but  its not installing to the device , what i need  to downgrade to 4.6.1 jde  i   downloaded the  jde 4.6.1 version but still when i  try to install  from cmd promt its giving me error The specified module was rejected by the device and cannot be loaded

I am using  8900 blackberry curve device 

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: The specified module was rejected by the device and cannot be loaded

[ Edited ]

I recommend that you upgrade your 8900 to OS 5.0 or get a newer device that does run OS 5.0.  I my opinion, you are wasting your time developing enything for OS 4.6.  It is old and the Browser is not that great especially when compared with the later devices. 

New Contributor
Posts: 4
Registered: ‎02-27-2014
My Device: device version : 4.6.1.310 (platform 4.2.0.127) 8900 Smart Phone(Edge Wifi)
My Carrier: ETISALAT

Re: The specified module was rejected by the device and cannot be loaded

My device version is  4.6 and I when i deploy to device Iam getting error "The specified module was rejected by the device and cannot be loaded"  .Can  any one help me   how to compile my application  for  4.6 ie in  JDE 4.6 .Iam using the Webworks sdk and trying to build a HelloWorld application using html5 and trying to deploy in my Blackberry Curve device its software version is  4.6 .

How to compile the application by 4.6 jde to run and deploy my hello World application to my Blackberry  Curve 8900 device

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: The specified module was rejected by the device and cannot be loaded

Repeating thew question is not going to help here.

 

AFAIK, WebWorks does not support the level of OS you have on your device.  So upgrade your device.

 

In fact you are asking this question on the wrong forum.  I suggest you ask your question in the forumm that deals with WebWorks here:

http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/bd-p/browser_dev