Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 44
Registered: ‎06-16-2009
My Device: Not Specified
Accepted Solution

Touch Screen newbie question

Hey friends,

 

I have to develop an app that will work specifically on Storm, Storm2, and Torch (Blackberry touch screens).

 

Which JDK level do I need to use?  I was thinking 4.7, but I was wondering if I should just use 5.0 as my API level?

Developer
Posts: 2,268
Registered: ‎07-08-2009
My Device: various
My Carrier: various

Re: Touch Screen newbie question

Personally, I would start with 5.0.  While it's true that Storms initially shipped with 4.7, most people have upgraded them ASAP because 4.7 was way too bad (all people I know with Storms cursed it like there is no tomorrow for as long as they had 4.7 and upgraded immediately to 5.0 when it became available).

 

I don't think there are enough people left with 4.7 to justify losing on the extended functionality.

----------------------------------------------------------
please click 'Accept Solution' on posts that provide the solution to the question you've posted. Don't say "Thanks", press 'Like' button instead!
Highlighted
Developer
Posts: 50
Registered: ‎12-23-2009
My Device: Not Specified

Re: Touch Screen newbie question

See the official RIM statistics of the applications downloading per OS version:

AppWorld download statistics