Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

New Member
Posts: 1
Registered: ‎05-08-2013
My Device: curve
My Carrier: verizon

Unable to get the bb dev tools running

Well, I've tried basically all day to get these tools running. Im running on OS X snow leopard. 


I've tried a fresh install of eclipse with the BB plugin


I've tried using the JDE from RIM


I've had two main issues

1) when trying to do various tasks  I get an NPE

2) I also get an error message indicating that the preprocessor is configuring and a restart is required but that fails and I get a message saying I have to reinstall the plugin. i've done this reinstall several times now  but I wind up with the same broken environment.


Any ideas? Im shocked at how awful and experience this is. No wonder RIM is dying.

Posts: 17,017
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Unable to get the bb dev tools running

welcome to the support forums.

the JDE is a legacy environment. I suggest that you use eclipse+plugin.
check developer.blackberry.com for details.
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter