Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
New Member
Posts: 1
Registered: ‎05-08-2013
My Device: curve
My Carrier: verizon

Unable to get the bb dev tools running

Well, I've tried basically all day to get these tools running. Im running on OS X snow leopard. 

 

I've tried a fresh install of eclipse with the BB plugin

 

I've tried using the JDE from RIM

 

I've had two main issues

1) when trying to do various tasks  I get an NPE

2) I also get an error message indicating that the preprocessor is configuring and a restart is required but that fails and I get a message saying I have to reinstall the plugin. i've done this reinstall several times now  but I wind up with the same broken environment.

 

Any ideas? Im shocked at how awful and experience this is. No wonder RIM is dying.

Highlighted
Developer
Posts: 17,025
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Unable to get the bb dev tools running

welcome to the support forums.

the JDE is a legacy environment. I suggest that you use eclipse+plugin.
check developer.blackberry.com for details.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter