Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
Posts: 35
Registered: ‎01-10-2010
My Device: 8310 and 9000
My Carrier: no idea

Using BlackBerry special symbols as part of data post

Hi,

 

I want to use the characters shown as part of the 'sym' key on BlackBerry.

 

The problem is all frequently used characters like & , > , <, ! , @, # , $ , % , ^ , * , ( , ) etc when selected get saved fine and the required screen on Blackberry also displays the saved data properly.

 

However, in those set of symbols, there are certain other special ones, which look like the epsilon symbol and a few such.After I select them and click on save, the data doesn't show up on blackberry screen and the data post fails. Also no error is getting thrown in the logs for this.

 

Any ideas/ suggestions as to what could be the possible reason ?

 

Please find an attachement that shows the required ones encircled in red.

 

Hoping for some quick pointers.

 

Thanks in advance


 

New Developer
Posts: 35
Registered: ‎01-10-2010
My Device: 8310 and 9000
My Carrier: no idea

Re: Using BlackBerry special symbols as part of data post

Can it be a charset type issue...like latin or utf-8 types..? just a guess..not too sure on this..

 

BlackBerry Development Advisor
Posts: 15,723
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Using BlackBerry special symbols as part of data post

What does your save button do?  How are you trying to display the characters?  What BlackBerry Smartphone model and BlackBerry device software version are you testing on?  You can find this under Options, About on the BlackBerry Smartphone.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker