Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 22
Registered: ‎09-10-2008
My Device: Not Specified

Using rapc -> "Warning!: No entry points found"

 

For some of my Java apps I am having problems using rapc to create my cod file.  I get the following output:

Building Bridlet
C:\SDKs\RIM\BlackBerry JDE 4.6.0\bin\rapc.exe  -quiet import="..\..\SDKs\RIM\BlackBerry JDE 4.6.0\lib\net_rim_api.jar" codename=Bridlet\dist\BB460\Bridlet -midlet Bridlet\dist\BB460\Bridlet.rapc warnkey=0x52424200;0x52525400;0x52435200
Warning!: No entry points found
Warning!: MIDlet class is not public: Bridlet.Midlet
Bridlet.Midlet: Warning!: No definition found
Build complete.

Sometimes I only get the first of the three warnings.  Either way, the midlet fails to run in my simulator.

Here are the details:

I'm building both MIDlet's and Rimlet's using Blackberry JDE 4.6.0 on Vista SP1., with java 1.6.0_11.

I build the JAR using Netbeans v6.5 (the current version) and then build and sign the COD using the BB IDE v4.6.

For RIMlet's this works fine, it is only MIDlet's that are giving me the problem.  One of the differences between the two is that for MIDlet's I have specify the name of the MIDlet class in the project properties.  The field is called "Name of main midlet class" on the "application" tab.  I'm a bit confused about this field and I wonder whether this is where my problem lies.  The SDK includes a sample midlet and it specifies "com.rim.samples.device.midletdemo.MIDletDemo" for this field.  This appears to be <package>.<midlet class> so I followed this pattern.

 

Any suggestions?

BlackBerry Development Advisor
Posts: 15,752
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Using rapc -> "Warning!: No entry points found"

I think your assumptions on the cause are correct.  This sounds like a problem with the main MIDlet class you have specified.  It should be in the format of package.className and the class specified should be the main class for your MIDlet (extends MIDlet).  Also verify that the required methods (startApp, pauseApp, destroyApp and your constructor) are marked as public.
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Highlighted
Developer
Posts: 22
Registered: ‎09-10-2008
My Device: Not Specified

Re: Using rapc -> "Warning!: No entry points found"

Mark,


Good point - I just checked and some of those members are not marked public.  My midlet class seems to have been specified correctly.

 

Thanks,

Tom.