Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
Posts: 4
Registered: ‎02-19-2009
My Device: 8820
Accepted Solution

Wap browser installation error ---- myapp-1.cod 404 not found

Hi all Experts,

 

I am new in BalckBerry Development.I have developed one application and have tested it on simulator and Blackberry phone.

 

While testing on phoneI used BlackBerry Desktop manager to install the application on the phone. Now I want to download it from wap browser and install on the phone so that any one can install it.But I get following Error while installing from the wap browser.

 

"myapp-1.cod 404 not found"

 

I have put following files in the Server 

1. myapp.cod

2. myapp.jad

3. myapp.csl

4. myapp.cso

5. myapp.alx (I used this file for installation using BlackBerry Desktop Manager)

 

Do I require to put any other file for this ?

 

 

When I debug this I found that my jad file contains sh1 signature for files myapp-1.cod , myapp-2.cod , myapp-3.cod.

But I could not find  any of the above files.

 

Do I need to generate these files ?

 

 

 

 

Thanks , -- Vishal
Developer
Posts: 16,992
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Wap browser installation error ---- myapp-1.cod 404 not found

your cod-file is, in fact, a zip file (whenever your app is bigger then a certain amount, 64kb iirc). you can extract it using a zip software like 7zip, winzip etc.
there are possible combinations of BES, OS and transports that can cause errors in automatically extracting the zip, if you extract it yourself you are on the save side.
you do not have to edit anything in your jad-file.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
New Developer
Posts: 4
Registered: ‎02-19-2009
My Device: 8820

Re: Wap browser installation error ---- myapp-1.cod 404 not found

Thanks for the quick reply,

 

So you mean to say I need to extract the .cod file ?

 

I have winrar installed on my PC but it dosen't recogises .cod as compressed (zipped) file.Then how can I extract the files.

 

And also after Extracting I guess I am going to get that class files  -- right? but I need myapp-1.cod file. Howcan I get this file?

 

Thanks again.

 

-- Vishal

Thanks , -- Vishal
Developer
Posts: 16,992
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Wap browser installation error ---- myapp-1.cod 404 not found

if the cod file is larger then 64kb it is a zip file. i can use winrar from the context menu. if all failes change the extension to zip and try it then.

within the zip files are the sub-cod-files, like cod-1, cod-2 etc.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
New Developer
Posts: 4
Registered: ‎02-19-2009
My Device: 8820

Re: Wap browser installation error ---- myapp-1.cod 404 not found

Thanks buddy ,

 

 

I have changed the extension of the cod files and I did get the cod files compresed inside the main .cod files .

 

 

I will just try to install myapp using these .cod files

 

-- cheers

Thanks , -- Vishal
New Contributor
Posts: 2
Registered: ‎02-22-2011
My Device: 8300
My Carrier: Software Engineer

Re: Wap browser installation error ---- myapp-1.cod 404 not found

[ Edited ]

Hi, I have the same problem but when I change extension from cod file to zip I getting an error: "Can not open file: It does not appear to be a valid archive". any help?

My cod file have 62KB but my jad file have the text: RIM-COD-URL-1: xxxx-1.cod

 

Thank in advance

Developer
Posts: 16,992
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Wap browser installation error ---- myapp-1.cod 404 not found

 

welcome to the support forums.

 

please open a new thread and link to the existing one in the future, you will get more replys this way as people tend to ignore solved threads.

 

your cod file most likely is not a zip file but just a cod. if it grows bigger than 64kb it will be, and you will see a xxx-2.cod reference in the jad.

clean your build (delete jad+cod) and re-compile, maybe the jad file is from an older build.

if the problem persists open an own thread.

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Highlighted
New Contributor
Posts: 2
Registered: ‎02-22-2011
My Device: 8300
My Carrier: Software Engineer

Re: Wap browser installation error ---- myapp-1.cod 404 not found

Thanks, It works. My jad file was with wrong data, but clean al build doesn't delete jad file I have to delete it manually