Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

New Developer
Posts: 30
Registered: ‎11-25-2009
My Device: Not Specified

Warning!: No entry points found

After starting the 9000 simulator under Eclipse 3.5.3 and 1.1.2 plugin the simulator failed to load. Since this has happened in a variety of ways, I then uninstalled everything and removed any references to Eclipse on my 32-bit WinXP system (for some reason, my app worked fine and dandy before I "upgraded" from Eclipse 3.4.2 to 3.5.2). I then d/led 3.5.2 from the Eclipse website, installed componentpack4.6.0_4.6.0.23 from BB plugins update site.


When I run the app as BB simulator, I get the following msg:


Packaging project JSR-GAME C:\eclipse-SDK-3.5.2-win32\eclipse\plugins\net.rim.ejde.componentpack4.6.0_4.6.0.23\components\bin\rapc.exe -quiet codename=deliverables\Standard\4.6.0\JSR-GAME deliverables\Standard\4.6.0\JSR-GAME.rapc -import=C:\eclipse-SDK-3.5.2-win32\eclipse\plugins\net.rim.ejde.componentpack4.6.0_4.6.0.23\components\lib\net_rim_api.jar C:\Documents and Settings\Roy\workspace\JSR-GAME\bin

Warning!: No entry points found Warning!: No definition found for exported static routine: .main(String[]) Packaging project JSR-GAME succeeded (took 1.047 seconds)


The cod and other files appear in the navigator tree. The simulator window opens (showing Blackberry 9000), shows the timer clock hand moving, then it stops. Troubleshooting suggestions welcome.

Trusted Contributor
Posts: 138
Registered: ‎07-11-2010
My Device: Bold 9700
My Carrier: O2

Re: Warning!: No entry points found

try adding an alternate entry point? (xml file in your project > alternate entry points)