Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 15
Registered: ‎06-11-2010
My Device: Pearl 8130
My Carrier: verizon

Web Service on www2 domain

[ Edited ]

Hi,

 

I have an old application that connects to a web server with a www.xxx.com domain, but now we have changed the domain to www2.xxx.com and the application doesnt work... In the simulator it works but in the device it doesnt.

 

This is a java application using RIM 4.5  and the plug-in 1.1.2.

 

Anybody can help me out with this issue please...

 

Thank you...

 

Jiovanni

Developer
Posts: 16,997
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Web Service on www2 domain

www2 is just a name, it does not make any difference for the connection.
do you have the 4.5 JRE installed? just asking because it is no longer available.
do you see any exceptions? maybe in the device log (alt+lglg)?
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Contributor
Posts: 15
Registered: ‎06-11-2010
My Device: Pearl 8130
My Carrier: verizon

Re: Web Service on www2 domain

Hi Simon,

 

I have the 4.5 installed in my laptop...

I changed the name to the ip address and it is the same thing, doesnt work...

this is the log:

 

#BlackBerry Event Log (cpt)

#HwID: 0x4000f07

#DPIN: 0x2674e0e7

#PVer: 6.3.0.67

#AVer: 5.0.0.997

¿ System - JVM:INFOp=2674e0e7,a='5.0.0.997',o='6.3.0.67',h=4000f07 - 2/8 10:07:43

¿ System - AMGF net_rim_event_log_viewer_app(1871) - 2/8 10:07:43

¿ System - AMNF net_rim_event_log_viewer_app(1871) - 2/8 10:07:43

¿ System - AMSF net_rim_bb_ribbon_app(93) - 2/8 10:07:38

¿ System - AMNF net_rim_bb_ribbon_app(93) - 2/8 10:07:38

¿ System - AMFD SIGE(1870) - 2/8 10:07:38

¿ net.rim.ippp - RXCd   61 - 2/8 10:07:35

¿ net.rim.ippp - TXst   494 - 2/8 10:07:31

¿ BBM - RXCd 0x20000372d479d8c - 2/8 10:07:29

¿ System - AMGF SIGE(1870) - 2/8 10:07:26

¿ System - AMNF SIGE(1870) - 2/8 10:07:26

¿ System - AMSF net_rim_bb_ribbon_app(93) - 2/8 10:07:25

¿ System - AMNF net_rim_bb_ribbon_app(93) - 2/8 10:07:25

¿ System - AMFD net_rim_event_log_viewer_app(1869) - 2/8 10:07:25

 

It makes any sense to you??

do you think this is something about the AMSF net_rim_bb_ribbon_app(93) ??

 

Thanks for your help,

 

Jiovanni

Developer
Posts: 16,997
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Web Service on www2 domain

no, the logfile does not contain any information about the connection.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Contributor
Posts: 15
Registered: ‎06-11-2010
My Device: Pearl 8130
My Carrier: verizon

Re: Web Service on www2 domain

I got the exception when the app is waiting for web service response:

 

unexcepted type (position:TEXT Connection Timed…@1:37 in java.io.InputStreamReader@b87baab)


any idea??

 

We are using BES v.5, maybe some setting to allow www2 connections??

 

Thanx

Developer
Posts: 16,997
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Web Service on www2 domain

most likely you get a http error. if you use ksoap it is not able to work with these by default, you have to add the functionality.
we added it by overwriting openInputStream in ServiceConnectionMidp and checking for the response code there.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter