Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

New Contributor
Posts: 9
Registered: ‎05-02-2010
My Device: Curve 8900
My Carrier: Rogers

Weird problem with simulator

Hi guys,


I am seeing a very weird problem. No matter what change I make to the source code, when I launch the simulator using the Run or Debug button, it launches with my app in the same state as before.


Which file is used by the Simulator? Is it the jad file?

I deleted he .jar, .jad, .debug, .jdp and .rapc and the class files in the bin folder to try to force a rebuild. 

That didn't work.

I also tried Project->Clean.


Finally running clean.bat has removed it, but when I run from source code my app does not show up on the simulator. 


All this while the simulator launched even if I put intentional compiler errors in the code.


Does anyone know if I have accidentally screwed up some important setting (I don't even remember what all I  have changed while trying to debug this Smiley Sad


Posts: 656
Registered: ‎02-03-2010
My Device: Z10 LE
My Carrier: Rogers

Re: Weird problem with simulator

I've seen this too many times unfortunately.  Here is what I usually try in order :


1) Delete all the folders under Delivarables.


2) Run Clean.bat to make sure simulator is clean.


2) Restart Computer


3) Restart Eclipse


4) Try again. 


5) If the app still doesn't load then I create a new project and copy the old one over.


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
Posts: 31
Registered: ‎11-28-2008
My Device: Not Specified

Re: Weird problem with simulator

[ Edited ]

I remember something like this happening to me a long time ago. I think it was that the debugger was never getting attached to the simulator. Aside from going to Debug->Attach to...->Simulator, I am not sure how else to force it to attach.


The simulator uses the cod file for running your app. There are a couple things you could try. You could go into the simulator and delete it from there, then go to File->Load Java Program... then find the .cod file that you built.


The other thing to look at is your project itself. If your app isn't showing on the simulator after running clean.bat, then it sounds like your project has been deactivated. Just activate it and it should start deploying again.


NOTE: This is assuming you're using the JDE. If you're using eclipse, then I'm not sure.

Posts: 950
Registered: ‎06-22-2010
My Device: 9550

Re: Weird problem with simulator

Restart Application with the new Project.

First Reatart Ur Computer also.

Regular Contributor
Posts: 68
Registered: ‎03-17-2010
My Device: 9000,9500,8900
My Carrier: Airtel,Vodafone

Re: Weird problem with simulator

Hi all,


May be this suggestion is somewhat weird.


But are you sure the application is Active in your IDEs.


In eclipse active projects have Darker folder icons and in JDE the active projects are written in bold fonts.


If not then you can activate the application. Coz AFAIK only the active projects are reflected in simulators...