Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
Posts: 23
Registered: ‎06-19-2009
My Device: Not Specified
Accepted Solution

Which version to use? 4.2? 4.5? 4.7?

In order to support older blackberrys you need to pick an old enough JDE. That's nice, except I can't find any dates associated with the JDE versions. At least if there were dates I could say to a user, your version is n months old so we don't support version that old.

 

What is the release dates on the versions?

Developer
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Which version to use? 4.2? 4.5? 4.7?

Dates are irrelevant. The OS version on the device is the key.

 

JDE 4.2.1 is a good base version - this is the oldest OS that is still shipping (AFAIK). A program compiled on this level  will run on a device with 4.2, 4.3, 4.5, 4.6.

 

However, for 4.7, I would suggest a 2nd build to cover the touch devices. While the 4.2 build wil run (in compatibility mode), your users won't like it.

 

 

 

 

New Developer
Posts: 23
Registered: ‎06-19-2009
My Device: Not Specified

Re: Which version to use? 4.2? 4.5? 4.7?

BTW, the dates do matter. If 4.2 stopped shipping last month we'd still support it. If it stopped shipping 2 years ago we would not. 

 

Without the dates we cannot know which version to support.

Developer
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Which version to use? 4.2? 4.5? 4.7?

We base our release level decisions on the device population.

 

Regardless of whether an OS is shipping or not, or when it stopped, the number of devices running the OS level is the salient data point (for us).

 

I think that based on *our* user statistics, 4.2, still runs on a significant portion of these devices in the field.

 

...your mileage may vary...