Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 30
Registered: ‎04-13-2010
My Device: N/A
My Carrier: T-Mobile

Why am I getting this error when i try to build the program

[ Edited ]

Why am I getting this error in my BB JDE when I try to build the program?

 

I use Windows Vista, BB V. 4.6.1

Jdk 1.6.0_17

 

I already added to the PATH variable "C:\Program Files\Java\jdk1.6.0_17\bin" and it still doesnt work!

 

http://img63.imageshack.us/i/errormv.jpg/

Thanks,
Saula
Your neighborhood programmer.
http://homeworkjava.com
Developer
Posts: 1,807
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.3.2.858, Z10 (STL100-3)-10.3.1.2576, Z30 (STA100-5)-10.3.1.2582, Passport (SQW100-1)-10.3.1.2576, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: Why am I getting this error when i try to build the program

Please post an external link to the image as it cannot be seen or type in the error message. Thank you.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Contributor
Posts: 30
Registered: ‎04-13-2010
My Device: N/A
My Carrier: T-Mobile

Re: Why am I getting this error when i try to build the program

oops sorry here http://img63.imageshack.us/content_round.php?page=done&l=img63/9048/errormv.jpg&via=mupload

Thanks,
Saula
Your neighborhood programmer.
http://homeworkjava.com
Developer
Posts: 1,807
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.3.2.858, Z10 (STL100-3)-10.3.1.2576, Z30 (STA100-5)-10.3.1.2582, Passport (SQW100-1)-10.3.1.2576, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: Why am I getting this error when i try to build the program

Do you have the Java JDK installed?

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Developer
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Why am I getting this error when i try to build the program

If the JDK is isntalled, then also check your Windows PATH environment variable. This should include the path the the JDK/bin directory so that the JDE can locate the java compiler.

 

Contributor
Posts: 30
Registered: ‎04-13-2010
My Device: N/A
My Carrier: T-Mobile

Re: Why am I getting this error when i try to build the program

I did all that and it still doesn't work smh . Yes i have JDK installed

Thanks,
Saula
Your neighborhood programmer.
http://homeworkjava.com
Highlighted
Developer
Posts: 1,807
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.3.2.858, Z10 (STL100-3)-10.3.1.2576, Z30 (STA100-5)-10.3.1.2582, Passport (SQW100-1)-10.3.1.2576, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: Why am I getting this error when i try to build the program

Are you sure the PATH is correct?I looked up the error code ("error=2") and found this. They had a link to a KB article on getting that or similar errors.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Developer
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Why am I getting this error when i try to build the program

Open a command window and run "javac"

 

If it does not start the java compiler, then your JDE won't be able to, either.

 

 

 

Contributor
Posts: 30
Registered: ‎04-13-2010
My Device: N/A
My Carrier: T-Mobile

Re: Why am I getting this error when i try to build the program

It starts my java compilier when i typed in "javac" but it still won't compile smh. Dam it Blackberry!

Thanks,
Saula
Your neighborhood programmer.
http://homeworkjava.com
Developer
Posts: 1,807
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.3.2.858, Z10 (STL100-3)-10.3.1.2576, Z30 (STA100-5)-10.3.1.2582, Passport (SQW100-1)-10.3.1.2576, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: Why am I getting this error when i try to build the program

[ Edited ]

Do you have multiple versions of the JDK installed?

 

I'm just going through what I can find for the exit code of 2. Since it says "CreateProcess error=2" and says that the file is not found I am assuming it can't find javac, I read that if multiple JDKs are installed that it the versions might not match and it won't work.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.