Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

New Contributor
Posts: 2
Registered: ‎07-08-2012
My Device: Curve
My Carrier: Vodacom

Zend Studio simulation problems for Java

Dear Community,


Been searching around for a solution to a small issue I have when attampting to run a simulation of my first app using Zend Studio.


My environment:


MAC OSX - 10.6.8

ZEND STUDIO professional edition 9.0


I have downloaded and installed the Blackberry Java SDK addon for Zend Studio (Eclipse) using: help -> install new software -> Blackberry Java Pack


This seemed to go smoothly.


I am now following my first tutorial to get the hang of creating apps: http://docs.blackberry.com/en/developers/deliverables/30946/Creating_your_first_app_1806946_11.jsp


All has worked fine up until the "Run your app in a simulator"


"Right-click the project, and then select Run As > BlackBerry Simulator."


When I right click on the "run as", the "Blackberry Simulator" is not available, so I instead: "Run configurations".


Unable to start simulator. Check that the file exists. (java.io.IOException: Cannot run program ""/Applications/Zend" (in directory "/Applications/Zend Studio.app/Contents/Resources/Java/plugins/net.rim.ejde.componentpacl7.1.0_7.1.0.33/components/simulator") error=2, No such file or directory)


Checking I see the location does exist, so not 100% certain why it is not finding the location.


In addition I get the following error when I run the simulator for the first time:

Eclipse configuration file /Applications/Zend Studio.app/Contents/Resources/java/Eclipse.app/Contents/MacOS/eclipse.ini was not found.


I could not figure out how to rename this location since it is not eclipse.app / eclipse.ini, the file is zendstudio.app and zendstudio.ini, so I renamed the files...


Further errors I have received:

The preprocessor hook could not be configured correctly. You may need to reinstall the BlackBerry Eclipse plug-in.


If anyone is using Zend Studio with the Java sdk I would be greatful for some insights in how to get this all working.


Many thanks,


- Brendan