Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 26
Registered: ‎07-26-2010
My Device: Not Specified

cannot run build.xml

I have installed blackberry jde plugin which supports 6.0,4.7,4.6,..

i have imported legacy projects from eclipse 4.6 workspace.

the folder structure includes build.xml in 4.6 eclipse which is not appearing new eclipse.i have created new build.xml and copied bb-ant-tools.jar and when i try to run nth is happening.

 

but when i configured eclipse with blackberry plugin in usual way of available software etc build.xml reflects in folder structure.

 

so what shud be done in the case earlier

 

thanks,

kusuma

Developer
Posts: 17,017
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: cannot run build.xml

welcome to the support forums. the BB eclipse plugin does not work with ant anymore, you don't need the build.xml anymore. check a tutorial about eclipse+plugin if it does not work out of the box for you.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Highlighted
Developer
Posts: 50
Registered: ‎07-17-2008
My Device: 8310

Re: cannot run build.xml

you can use Ant with below trick.

 

- drag build.xml to Ant window

- right click the target, select "2, ant", which will open confiuration properties.

- click tab JRE, change "BlackBerry JRE xxxx" to "JDK 1.6xxx"

- click start.

 

The simple reason is, you should use J2SE JDK to run ant.

William

EasyDialer -- Calling card dialer, Google Voice Dialer, Conference Call dialer! Relieve the pain of dialing lengthy numbers...
----------------------------------------
If you love it, please let friends know.
If you hate it, please let me know.