Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
Posts: 66
Registered: ‎11-23-2009
My Device: Not Specified

code signing tool not loading all of a sudden?!

Hello,

 

I have been making code signed applications on JDE 4.5, 4.6 and 4.7 for about 2 or 3 months now.

 

I use Display.getWidth() so I need to sign all of my code for distribution on the App World store.

 

Signing has been going great until today. Now the code signer app does not load.

 

Here is what I do:

I click build all.

Click Generate ALX file.

Click Request Signatures.

 

Then the Signature Tool usually loads and I sign about 50 signatures.

 

Now it's not loading at all. I REALLY need it to work because I absolutely have to sign some code today.

 

In JDE 4.6.0, it just says this in the Output:

 

javaw.exe  -jar "C:\Program Files\Research In Motion\BlackBerry JDE 4.6.0\bin\SignatureTool.jar" -f -d "C:\Documents and Settings\Administrator\Local Settings\Temp\RIMSigTool4465566571751627807.tmp"

 

javaw.exe  -jar "C:\Program Files\Research In Motion\BlackBerry JDE 4.6.0\bin\SignatureTool.jar" -f -d "C:\Documents and Settings\Administrator\Local Settings\Temp\RIMSigTool4465566571751627807.tmp"

 

What's worse, JDE 4.7.0 has the Request Signatures button grayed out.

 

Is there some kind of expiration to the keys that I didn't know about?

Highlighted
New Developer
Posts: 66
Registered: ‎11-23-2009
My Device: Not Specified

Re: code signing tool not loading all of a sudden?!

My apologies, I did not have the project activated.

 

A note for anyone experiencing this problem:

 

You must go to Project -> Set Active Projects... and then make sure your project is active before you can sign code.