Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Developer
Posts: 73
Registered: ‎05-03-2011
My Device: 9550
My Carrier: verison

compatible with variable OS version problem

hi, I want to know that if my program need to support OS4.6 OS5.0 or above,  do I need to download sdk4.6 and compile  and package it, is it enough?

My program developed under jde5.0, but all API is under OS4.6,  user report that "module net_rim_ui_api not found", so I wonder how to handle the compatible problem?

Author of pairs and Gradient
Developer
Posts: 263
Registered: ‎05-18-2011
My Device: Curve 9300, BB10 Dev Alpha C, Z10

Re: compatible with variable OS version problem

For me, if I want to develop for OSx.x and above, then I will write and compile code using JREx.x. In your case, you will need SDK4.6. That is all.
--tom
Developer
Posts: 87
Registered: ‎07-23-2009
My Device: Z30
My Carrier: XL

Re: compatible with variable OS version problem

I agree with tommy20, you should use SDK 4.6 if you targetting OS 4.6 and above.