Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Trusted Contributor
Posts: 138
Registered: ‎07-11-2010
My Device: Bold 9700
My Carrier: O2

confusion about eclipse and OS version

what is the minimum JDE version that's supported by eclipse (via the plug-in)? i'm reading threads around here and the responses seem to vary -- some suggesting 4.3 and above and some 4.2.1 and above.

Developer
Posts: 499
Registered: ‎06-24-2008
My Device: Not Specified

Re: confusion about eclipse and OS version

I have a plugin installed for 4.2.1 and all OS levels since.

 

Having said that I'm not sure how many 4.2.1 users are out there. And building apps for all the releases is time consuming.

 

I'd be interested to hear if any developers are still having 4.2.1 downloads.

Trusted Contributor
Posts: 138
Registered: ‎07-11-2010
My Device: Bold 9700
My Carrier: O2

Re: confusion about eclipse and OS version

which would you say is the lowest common OS? it's just that i've made an app with the 5.0 jde but realised that many of the functions i used are supported by lower OS versions.

Developer
Posts: 499
Registered: ‎06-24-2008
My Device: Not Specified

Re: confusion about eclipse and OS version

Good question.

 

Unfortunately not one for which I think there is an easy answer.

 

Over the past three months I've had 75% of downloads (17,000) using OS5.0. I forget the exact numbers but around 10% downloaded using 4.6 and a similar amount 4.5.

 

I've never released software for 4.2 so can't say. Some time ago one of the experienced developers on here said they still had lots of downloads of 4.2.

 

The question I ask myself is whether it's worth supporting earlier software releases when we're about to move to OS6.

 

I takes me quite a but of time to build the five OS levels I support and deploy. Not to mention providing support for each OS.

 

So I've more or less decided to support only 5 and above. I'll lose potential customers but have more time to develop new apps and have less headaches with support.

 

I'd be interested to hear anyone elses experiences.

Developer
Posts: 1,746
Registered: ‎04-08-2010
My Device: Passport Silver, PRIV
My Carrier: Telekom.de, O2, Vodafone

Re: confusion about eclipse and OS version

I made the same decision: supporting 5.0 and above

some of the new UI elements from 6.0 I have build similar things for 5.0,

so I think its ok for me to support 5.0 / 6.0 with similar looking apps

 

I know that I'm loosing potential customers, but I started BB development new in march this year and from beginning focused on 5.0 - perhaps if most devices will be upgradable to 6.0 at one point I'll only support 6.0

 

think decisions also depend from the market you target geographically - heard that in germany (my main target)  most devices have newer OS versions but in US many exist with old versions

 

...not easy...

-------------------------------------------------------------------------------
ekke (independent software architect, rosenheim, germany)

BlackBerry Elite Developer
BlackBerry Platinum Enterprise Partner
International Development native Mobile Business Apps
BlackBerry 10 | Qt Mobile (Android, iOS)
Workshops / Trainings / Bootcamps

blog: http://ekkes-corner.org
mobile-development: http://appbus.org Twitter: @ekkescorner