Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
Posts: 4
Registered: ‎08-28-2012
My Device: N/A
My Carrier: N/A

.csl files are not being generated.

[ Edited ]

Hello all,

 

For some reason the .csl files are not being generated whenever I build any of my applications. I tried reinstalling the JDE (both versions 4.3.0 and 4.7.0) and both are giving the same results. All the files, .cod, .cso, etc... are being generated except for the .csi files, which is causing me a probleme since the RRT required signatures are missing because of that, which are in turn causing the application to throw a verification error 2905.

 

I know for the 4.7.0 I can use this fix http://supportforums.blackberry.com/t5/Testing-and-Deployment/Signing-does-not-apply-the-RIM-Runtime... but how can I solve it for the 4.3.0 JDE?

 

I tried reinstalling netbeans, upgrading from version 6.9 to 7, and none of it solved my problem.

 

I'm using Windows 7 32 bit, and the JDK 1.6.

 

 

I should note that I recently downgraded from JDK 1.7 to JDK 1.6, since I had a problem running the signing tools on 1.7 and I saw in the forums that they are not yet supported for that version. I am not sure whether this had anything to do with this.

 

Any way to fix the generation of the .csl  files?

BlackBerry Development Advisor
Posts: 15,784
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: .csl files are not being generated.

That fix for missing RRT would apply to version 4.3.0 as well.  To automate the workaround you could create a .csl file and add a post build step to your project that copies that file to your project directory.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Highlighted
New Contributor
Posts: 4
Registered: ‎08-28-2012
My Device: N/A
My Carrier: N/A

Re: .csl files are not being generated.

Hey Mark,

 

Thank you for your reply. 

 

The weirdest thing happened. I found out I was packaging the LWUIT library twice, once inside my LWUIT-RIM jar, and once inside the main project (as well as another library). This gave me a completely unrelated error when I was running the app; You must include the platform port before the LWUIT in the classpath.

 

I solved this error by packaging the generic LWUIT only inside the LWUIT-RIM library and not the other projects, and for some weird reason, this actually fixed the problem of Netbeans not generating the .csl file.

 

Thank you again for your help.