Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Posts: 17
Registered: ‎07-17-2009
My Device: Not Specified
Accepted Solution

issues with Different Simmulators, garbage input showing

i am new to BB dev, hope i can get help on this one.


i have a application running on BB, on following simulators perfectly

8330, 8800 and 9000, though it works fine but a unexpected behavior is observed for following simulators 8100, 9530(beta and RC)



the un expected behaviour is comin from the following code, please advise, also note that it is working good the way expected  in mentioned 3 sims.



We have a screen which has custom made text fields (extends BasicEditFields), i have made it read only, by implementing KeyChar() and storing the key in place holder with in the field, please note we are not modifying the text entered in the filed it self on the screen.


I have sepratly written the ChangeField Listener in another class implementing the screen and registered it ias a listener.


Now the normal out put being observed is : when i press any key on the readonly field, the key gets stored in a place holder and is later fetched back from some other part in the app. how ever the field it self shows no key that was pressed earlier.


Abnormal behaviour being observed on mentioned simulators: when i press any input it starts repeating the last word concatinated along with the entry and this thing keeps going on




1. Key Char never gets called for the simulators showing abnormal behaviour

2. i dont nodify the test of the field but i still end up with garbage entry.

3. the change field is directly called with out going into the keychar.



im  also concerned that the code may not be wrong as it is working the right way for some simulators, any post on this one would be appriciated, 



Posts: 17,025
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: issues with Different Simmulators, garbage input showing

suretype seems to work before keychar comes into play.
if you handle a reduced keyboard layout as on the 8100 you can not get the character that matches the key pressed because there is no method published that does this.
i had several service tickets open but i only got confirmation that it can not be done.

at least on the 8100 i was able do disable suretype using a menu hack (see post below):

i have not tested this on the storm, but it may help you in your case.
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Posts: 17
Registered: ‎07-17-2009
My Device: Not Specified

Re: issues with Different Simmulators, garbage input showing

This was a nice way out, in addition i would like to wright down the solution that worked for me.


i actually used the "



this made it p[ossible for going to multi tap, and apparently the flow and application is back on track.