Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Regular Contributor
Posts: 67
Registered: ‎11-14-2010
My Device: 9900 7.0 PAQUETE 2395 (V7.0.0.579,PLATAFORMA 5.0.0.735)
My Carrier: MOVISTAR Venezuela
Accepted Solution

linker error Verify error

i can not run the program yet i have tried everyrhing changing all package names erasing all files but jdp compiling cleaning etc it compiles ok but never runs this has happened after i try to use some third party classes downloaded from devcon how i can find the line thatr arises the error

 

now i get in debug window 

 

 

Starting ElRecreoGPS
VM:LINK ElRecreoGPS
Class 'net.rim.device.api.ui.ScrollView' not found.
Linker error: 'VerifyError' for ElRecreoGPS
VM:CLRCv=0
Error starting ElRecreoGPS: Class 'net.rim.device.api.ui.ScrollView' not found.

Starting ElRecreoGPSVM:LINK ElRecreoGPSClass 'net.rim.device.api.ui.ScrollView' not found.Linker error: 'VerifyError' for ElRecreoGPSVM:CLRCv=0Error starting ElRecreoGPS: Class 'net.rim.device.api.ui.ScrollView' not found.

 

Developer
Posts: 17,019
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: linker error Verify error

 

class scrollview

Since:
BlackBerry API 6.0.0

 

my guess would be that you try to run an OS 6 application on a device with a lower OS.

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Regular Contributor
Posts: 67
Registered: ‎11-14-2010
My Device: 9900 7.0 PAQUETE 2395 (V7.0.0.579,PLATAFORMA 5.0.0.735)
My Carrier: MOVISTAR Venezuela

Re: linker error Verify error

My program always has worked the problems start when i try to add some dev files like coloured field and since them it builds sign but errors arise like error java lang modules not found etc there is no other wau to debug the application i have tried to compile with 4.7 but there are so many new modules in 6.o that it arises lot of errors

tks in advance

r.soler

Developer
Posts: 17,019
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: linker error Verify error

 

do you compile with OS 6?

does your blackberry have OS 6?

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Regular Contributor
Posts: 67
Registered: ‎11-14-2010
My Device: 9900 7.0 PAQUETE 2395 (V7.0.0.579,PLATAFORMA 5.0.0.735)
My Carrier: MOVISTAR Venezuela

Re: linker error Verify error

Yes compiled witjh 6 and torch always worked before
BlackBerry Development Advisor
Posts: 15,813
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: linker error Verify error

What BlackBerry device software version are you testing on?  You can find this under Options, About on the BlackBerry Smartphone.

 

Are you able to run the uiToolkitDemo that is included with the 6.0 BlackBerry Java SDK and 6.0 BlackBerry JDE?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Regular Contributor
Posts: 67
Registered: ‎11-14-2010
My Device: 9900 7.0 PAQUETE 2395 (V7.0.0.579,PLATAFORMA 5.0.0.735)
My Carrier: MOVISTAR Venezuela

Re: linker error Verify error

i am feeling really frustated keeps the same works on simulator when signed and upload to the device errors in classes now class multiople defined whish is false

torch sofware 6 package 695 (v6..0.0.246,platform 6.4.0.105)

 

jde same versio 6.0.0.246   when i try toattach to device error 

No debug information found for module 'net_rim_cldc'. Please ensure that you have installed the simulator package that m

and

No debug information found for module 'net_rim_os'. Please ensure t

tks in advance

r.soler

Developer
Posts: 17,019
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: linker error Verify error

 

you can ignore these error messages, they only say that the versions do not match, usually everything works fine.

 

classes multiply defined is a problem though, maybe you have a library with persistable classes or similar?

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Regular Contributor
Posts: 67
Registered: ‎11-14-2010
My Device: 9900 7.0 PAQUETE 2395 (V7.0.0.579,PLATAFORMA 5.0.0.735)
My Carrier: MOVISTAR Venezuela

Re: linker error Verify error

also the simulator version gives error and only works with the default simulator and version 141 when i try the 246 version it gives following errors

 

java.io.FileNotFoundException: C:\Archivos de programa\Research In Motion\BlackBerry Smartphone Simulators 6.0.0\6.0.0.246 (9800)\__ide_copyfile__.tmp (El sistema no puede hallar la ruta especificada)

 

java.io.FileNotFoundException: C:\Archivos de programa\Research In Motion\BlackBerry Smartphone Simulators 6.0.0\6.0.0.246 (9800)\__ide_copyfile__.tmp (El sistema no puede hallar la ruta especificada)

i reinstalled and same error

tks

r.soler

Regular Contributor
Posts: 67
Registered: ‎11-14-2010
My Device: 9900 7.0 PAQUETE 2395 (V7.0.0.579,PLATAFORMA 5.0.0.735)
My Carrier: MOVISTAR Venezuela

Re: linker error Verify error

yes i have several classes that implements persistable

public class Settings implements Persistable {

public class Placemark implements Persistable, Comparator

public static class WayPoint implements Persistable

but beore it worked fine

tks

r.soler