Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Posts: 79
Registered: ‎01-01-2009
My Device: Not Specified

project as library type

I remember on Eclpse 3.4xxx that option was under Project | Application...


Now I'm using 3.5 Galileo with 1.1 plugin  and it's not there anymore.


I can only find a reference to it in the Application Descriptor.


Where is it hiding now?



Posts: 17,024
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: project as library type

should be in the application descriptor xml, same as before iirc
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Posts: 79
Registered: ‎01-01-2009
My Device: Not Specified

Re: project as library type

it has been done,  it is there, 


but if I look at the  Project | Resource   window 

the Type is still Project


Type: Project


surely it compiles to a COD  but should't the project's type be shown as Libray? 



Posts: 1,807
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-, Z10 (STL100-3)-, Z30 (STA100-5)-, Passport (SQW100-1)-, PlayBook (16GB)-
My Carrier: Verizon

Re: project as library type

That's not going to change. It will always say "Project" for a BlackBerry project. You need to change the rapc compiler settings by doing what simon said, open the "BlackBerry_App_Descriptor.xml" file and make sure "Application Type" is set to "Library". That will do it.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.